Run away machine

I have had to reload LightBurn and everything else on a new computer.
I have Home at lower left.
When I give the start command it takes off quickly to the top right. Not sure how far it would go, I stop it knowing it is wrong.

Most likely you don’t have the correct workspace offset applied on the controller. CNC machines use negative workspace coordinates for somewhat arbitrary historic reasons, where dedicate laser systems use positive workspace coordinates. There are directions for setting that up here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

Didn’t find anything there that solved the problem.
I am on an XCarve 1000
If I select move to position 0, 0, it goes to the top right

That means you don’t have a workspace offset programmed. I don’t know the exact travel size of the XCarve, but it’s likely similar to the Shapeoko, and the commands for that are listed on the page I linked above, here: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#shapeoko

Specifically:

G10 L2 P1 X-812 Y-812

Entering the above line in the console and pressing enter will move your origin 812 mm forward and to the left. Assuming your machine has 812mm of travel on both axis, that would be the correct command.

Your machine might have more (or less) travel than that, so look up the correct number to use instead of the 812’s by typing $$ in the console and pressing enter. The settings shown for $130 and $131 are the X and Y travel lengths, so you’d use those values in the above G10 command instead of the 812’s I showed.

I passed by that thinking it was relevant to the X-Carve.
Thanks, I’ll go try that.

Made the changes… Now it wants to go forward and left and there is nowhere to go
$130 & $131 are both 719

Resolved…… Not perfect yet, but usable.

The numbers need to be negative, but I’m assuming you got that sorted. The simplest way to use this is to have it set up as a macro you can send to the machine when you want to use the laser.

You’ll also likely need $32=1 and $30=1000 (or $30=255, depending on how you have the S-Value Max set in the LightBurn device settings).

I will set up macros in the console
Thanks

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.