S_Scale=1000 needs to be 19050

im running a laser tree k30 24v head and works great in grbl software with the s_Scale set to 19050 but when i change lightburns perfs to same and machine settings set to the same it dont change output for the laser need help changing



Target buffer size found



















































Why would you use 19050 as a Smax?
any particular reason?

Seems you running a misken firmware
@misken might be able to help

That’s wrong. This value should be 1000. The same holds for the s-value max in LB device settings. If it’s my firmware version, you could reset it to 1000 by sending $RST=*, but if you changed any other values, those are also reset. So you might start by changing only the one value.

1 Like

Out of curiosity, why compile your own?
Any “good to have” features?

It’s an “historical” version :slight_smile: The first Sculpfun S6 and S9 lasers were shipped with a grbl-compatible (very close to MKS DLC) mainboard. The original firmware included some incorrect settings if you reset them to factory defaults. And it didn’t enable homing correctly. Since Sculpfun didn’t offer a firmware back then, you could only flash the “generic” firmware that was included in LaserGRBL, or compile it from source (what was difficult for many users). The LaserGRBL-version had even more generic default values.
That’s why I created a firmware file for all S6 and S9 lasers that included some changes (defaults optimized and homing cycle enabled, as well as M7 and M8 control, full change list is here: Firmware Update & Settings - Diode Laser Wiki).
Nowadays, those lasers are shipped with newer boards, so this is just a legacy version, I’d say :slight_smile: I didn’t know that it has been used for other brands as well :slight_smile:

Got ya!!!
Yeah more and more custom firmwares are a tough thing
Hope this trend changes and lets people do - if they dare - DIY aproach to firmware too.
Granted i know why brands do it, same why you cant change even plugs in your car without having the electronic scanned plugged in! :stuck_out_tongue:

With the S_Scale set to 1000 the laser couldn’t even mark a peice of poster borad lol at 1000 grbl software was scaling it at 5.2% power output once i changed the value to 255 i had the full power restored not at 1% power im cutting the poster borad and engraving stainless at 15% at 3000mm/m so just need to find a new borad and steppers so i can run faster then 6000mm/m any options from anyone thanks for everyones imput and help

sounding to me you might be running in mm/sec isntead of mm/min
By changing the scale what you are doing is basicly running at 100% all the time

I wasnt kicking at ur firmware and you are correct it was set to 1000 as you said but just wasnt enough output for my laser module and the page you posted on was helpful as hell best write up ive seen from any page

No, no. I didn’t take anything as criticism. :slight_smile: I even feel honored that the firmware took its way into other devices. :slight_smile:

The scale basically doesn’t mean anything related to the absolute power level of the laser. The only thing you have to make sure is that the s-value max is the same in the laser and the control software. It doesn’t matter if you put it at 5, 255, 1,000 or 10,000, as long as it’s the same value on both sides. The only thing that changes is the level of granularity of power levels.

You should be and I congratulate your efforts. Anyone that’s done any modifications of grbl or even a similar larger package has my gratitude.

8 bits give you enough to control up to 256 shades or granularity… I have yet to see a hobby laser (or anything else, laser wise) that has a resultant output that has the 256 shades of gray … let alone the 65,536 shades of gray for a 16 bit pwm machine.

IMHO, it’s not really gaining you anything, except, maybe somehow, peace of mind. :man_shrugging:


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.