S-value during travel not at S0 when in cut mode

Hey guys, this doesn’t let me sleep:

I use Lightburn with my HIGH-Z 1400 T, so I export GCode. In fill mode all works fine, no travel lines between fills. However, in cut mode the G-Code doesn’t adjust the S-value to S0 when traveling from one cut to the next. S only appears at the very start and the very end of my GCode.

Also I don’t find my machine/controller in the machine list when setting up a new machine, there might be a problem there? I took GBRL as it seemed to be most common… guess that’s not really an argument though :slight_smile:

I mean, I read all threads concerning that topic – in my understanding GCode should just switch off the laser with S0, no? Just like it does for the overscan in fill mode.

Puhh, hope someone can show me a way out of this…

Greetings from Berlin and thanks,

What is your controller?

In nearly all the controllers supported by LightBurn, a G0 move is known by the controller to be a non-cutting move, so it turns off the output. Even in ones that specifically require turning the beam off, like GRBL-M3, there’s a specific command used to turn on the laser (M3) and one to turn it off (M5), and the S command is only emitted when the power value changes.

Ok, I checked that: G0 isn’t turning off the laser nor the spindle in my case. That leaves me with two options. 1. use GRBL M3 or 2. manipulate GRBL GCode with some regex magic to insert S Values.

Is that correct? Are there any disadvantages using GRBL M3?

My controller is this one, it’s german and I’m really happy with it in every day CNC production in my company. Would be great to add laser to the stack. The machine/controller might be a little non standard in this matter :slight_smile:.

Cheers, Moritz

Using the GRBL-M3 profile would likely be simplest, if that works correctly. We’re going to be producing a generic CNC profile before too long, with a fully editable code generator, but that will take some time.

Edit: Disregard, didn’t realize that this is not a GRBL controller. Thanks Oz for the heads-up!

(Previous text: Moritz, could you check whether your CNC is in laser mode ($32=1)? G0 keeping the laser/spindle running sounds suspiciously like $32=0. Use the $$ command to check. As far as I know, this mode exists only for GRBL 1.1 and up.)

Andreas - He is not using a GRBL controller, and won’t have that setting, which is why I removed your previous post.

Hey Oz, thanks – I’ll try that and let you know. I any event, a generic CNC profile sounds awesome. Let me know if I can test anything. Also happy to help.

Thanks and keep up the great work!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.