S9 y axis not moving

I am having an issue which wasn’t present before. The y axis on the s9 sculpfun is not moving any more. I tried tightening and loosening the belts but still nothing. I can hear a sound as the machine is trying to move but nothing. X axis runs smoothly. Any help please as I am it’s getting so frustrating!!

Sometimes the set screw that holds the sprocket on the shaft of the motor comes loose. This lets the motor turn and make noise without moving along the belt.

Physically move (gently shove) the engraver head along the Y axis and make sure it’s not stuck or bound-up.

You should see the little tooth-pulley on the y axis motor turning. At some point you should see the set screw hole(s) and be able to test and tighten them with a metric Allen Wrench or hex-key.

Thanks for the tip but I had already made sure all screws were tighten.

Very oddly the next day I tried it again and it worked smoothly!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.