Saving G-Code files with no laser connected?


(Bill VanOrden) #1

Is this possible? I was going to send a file to a friend in reference to a discussion and was not able to save a G-Code file to reference in my message.

It appears that the machine, in my case a K40 with the SBASE MKS v1.3 controller, must be online to save the file. Is this correct or am I missing something?

Beevo (aka Bill)
Tempe, AZ


(Rick James) #2

LightBurn does not require you to be connected to the internet for any reason beyond license activation and this is not even required if you register and complete the ‘Request Offline Activation’ feature.

You will need to define a ‘Devices’ profile as the code generated will be specific to the firmware of the intended output laser device.

What happens when you try to select the ‘Save GCode’ button?

image

EDIT: Sorry, I misread and thought you were asking about being “online”.

Please post a screenshot of your entire LightBurn screen including showing the ‘Laser’ window.


(Bill VanOrden) #5

Her you go:

No save GCode button. I know I had done this once in the past. I am positive this is actually a Noob mistake, which I am willing to own up to…

:stuck_out_tongue:

Beevo (aka Bill)
Tempe, AZ


(Rick James) #6

It appears the ‘Beginner Mode’ has been turned ON (green). This changes the UI to remove more advanced features thus helping our new users. Going to the ‘Settings’ window and setting this to OFF (dark-red) will bring back the ‘Save GCode’ button in the ‘Laser’ window. Could this be the issue?

image

image


(Bill VanOrden) #7

Well I was pretty sure it was something simple.

:blush:

Thanks for the help. That may have gotten switched on a few weeks ago when I was exploring the software prior to getting the laser connected.

Beevo


(system) closed #8

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.