Scale Incorrect in software and also in positive numbers

If this has been asked before, I apologize but I’m really not sure how to search my issue. I believe I have a setting screwed up but I can’t find where. My grbl based machine (Openbuilds BlackBox) homes and moves correctly per the arrows so that is correct. The issues I have are:

1: The “scale” in the software and the machine are drastically different. If I use the “set laser position by clicking on the page icon” and click in the center of the workspace in the software, my machine takes off toward the back right rear corner. I had to stop it before it got there when I realized that it wasn’t even thinking about stopping in the center. I have no idea where it would have ended up had I not stopped it. If I click 3 or 4 boxes off of the lower right corner in the workspace, it will move out quite a bit more than the 5-10mm I am expecting.

2: This is another scale issue. The numbers in my software read positive numbers in the workspace and the numbers on my machine are in the negative. See below screen shots. The first screen shot shows the position after I homed and the second shows the position after I moved 10mm away from X home and 10mm away from y home. The numbers being reported by the machine are negative.

3: I’ve hit “Clear Origin” multiple times and tried to reset my origin to the lower left corner of my work piece. I hit “set origin” when I get the machine where I want it. I can move the machine 10mm (or whatever arbitrary number) away from where I just set origin, hit “go to origin” in the laser box and the machine goes elsewhere but doesn’t go crashing in to the limit switches which I am thankful for.

My current grbl settings for reference:
$$
$0=10
$1=255
$2=0
$3=7
$4=1
$5=0
$6=0
$10=1
$11=0.020
$12=0.002
$13=0
$20=0
$21=1
$22=1
$23=3
$24=100.000
$25=1000.000
$26=250
$27=5.000
$30=255
$31=0
$32=1
$100=199.100
$101=199.100
$102=199.100
$110=2500.000
$111=2500.000
$112=2500.000
$120=150.000
$121=150.000
$122=150.000
$130=824.000
$131=780.000
$132=122.000



workspace

#1 likely isn’t a scale issue, but where the OpenBuilds machine puts the origin. (I’ll elaborate with a link in a moment)

Your workspace dimensions aren’t 1000 x 1000, but the numbers below, in the firmware settings:

Those are the travel limits of the machine, so they’re what you should use for the working size. (824 x 780)

This link walks you through the workspace offset required for your machine to work in positive coordinates: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

The dimensions of your machine will be needed here too, for the workspace offset. The command for yours will be:

G10 L2 P1 X-824 Y-780

Thanks again Oz… I’ll give that a shot.

OK, to circle back, I got it working but there were multiple issues.

1: I recorded a macro for G10 L2 P1 X-824 Y-780 and another for G10 L2 P1 X-0 Y-0
2: I changed $10=1 to $10=0

The machine was still acting crazy (hit return to origin and it would go some random place, try to start a job and it would take off in the totally wrong direction, etc).

I then realized there was a MAJOR PEBKAC error. When I would force the machine to stop from crashing in to a rail or the machine hit a hard limit, I was only dismissing the alarm vs rehoming. Basically I forgot how to work a CnC machine because it had a laser attached to it.

Once I started rehoming after something random, everything started working as expected. The only issue I have now is working with the full size of the table in Lightburn vs defining my project size like I do in Vectric. I think I figured a way around that though by drawing a rectangle around my “workspace”, doing all of my work inside of that rectangle (like Vectric) and then turning off that layer for printing and being visible. I may end up “permanently shrinking my workspace” in the software so I don’t have that “huge” space to deal with and expand it if I need to.

Thanks again for all of the help and hopefully this post will help someone else in the future.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.