Sculpfun S-9 not recognized in Ubuntu 20.04.5

First post, please be kind. :slight_smile:

I finally got LightBurn (demo) set up and running in Ubuntu 20.04.5, connected via USB to a Sculpfun S-9.

I can see the device, i.e.:

$ lsusb

Bus 05 Device 004: ID 1a86:7523 QinHeng Electronics HL-340 USB-Serial adapter

$lsusb -t

Port 2: dev 4, If 0, Class-Vendor Specific Class, Driver=ch341, 12M

But LightBurn can’t “find” it on its own.

I also played around attempting to manually create a device, but I have no idea what kind of controller is in this laser, and I’ve searched quite a bit. Does anyone know what’s inside this device? Is it Ruida? GRBL? Compatible enough with any of the others?

I tried to make a GRBL device, just guessing, and haven’t been able to communicate with the device at all. It is running in a VM, out of necessity, but I can do stuff like printing via USB in the VM without any issues, so I can tell that the VM’s USB is working at least at the basic level.

I did add the primary user account to dialout and tty, so that was not forgotten.
Do I need drivers?


No. It’s likely something else.

2 things to check.

  1. See if a serial TTY device is being created. This needs to exist for you to have any chance at all of accessing it from LightBurn:
ls /dev/*USB*
  1. There’s a known issue with certain distributions where CH341 devices will get mapped to a braille reader type. This may be happening to you. Take a look at this post and see if this applies to you:
    Can't run Sculpfun s9 on UBUNTU - #14 by berainlb

Okay, I’m going to try to do as much as I can batch up at once, because the laser setup is in a different (offline) physical location, and i’m copying this manually. The link was good stuff, although I’m not sure it’s applicable. Various details:

$ lsusb (info above)

$ ls /dev/USB

So it appears to create a serial tty device. Doing the same command yields nothing when the device is not connected.

$ lsb_release -a
No LSB modules are available.

$ lsmod | grep ch341
ch341 24576 0
usbserial 57344 1 ch341

$ dmesg | grep ch341
… repeated sequences of:
ch341 5-2:1.0: ch341-uart converter detected
usb 5-2: ch341-uart converter now attached to ttyUSB0
  (try to use it here)
ch341-uart ttyUSB0: ch341-uart converter now disconnected from ttyUSB0
ch341 5-2:1.0: device disconnected

In the Laser window, to the right of the (Devices) button, the first item says “ttyUSB0” and the second one shows “GRBL”, which is just what I called my tester manual config.

From the link, I looked in /usr/lib/udev/rules.d/ there is indeed a file called
However, there is no match inside the file for 1a86 or 7523, so I didn’t muck with that file. I suppose I could just remove it, but without those vendor-specific numbers I didn’t think that would help.

Also, it would really help to know the controller for this device, and if GRBL is the appropriate device type to use for a manual profile, otherwise I can easily imaging the devices being connected, but not able to communicate.

I’m ready for the next thing to check!

GRBL is correct.

This seems fine. So the basic connectivity should be there.

What do you see in Console from LightBurn when trying to connect?

Can you take a screenshot of Edit->Device Settings?

Also, if you haven’t already, you may want to reboot the computer.

Okay, knowing it’s GRBL is useful, thanks.

Does LightBurn have its own console? Clearly I’ve barely touched the software, given that I haven’t been able to get it to even open until earlier today. I have tried to rummage through /var/log stuff, but that can be like sifting for gems on a beach full of sand if you don’t know exactly what you’re looking for… [edit; I see LightBurn does indeed have its own console. I will definitely look at that]

Also, that setup is entirely offline, so I can’t really capture and transfer a screenshot, but I’ll look at it and see if I can take notes on what’s there. If there are any particular settings I should take note of, please let me know!

re: rebooting; it’s on a VM, so it does get rebooted, but I don’t actually think it was rebooted today after LightBurn was installed, so I can try that as well.

Take a look at baud rate. I believe for your laser it should be 115,200. Also try toggling DTR signal but I don’t recall it being required for the S9. LightBurn has an S9 setup guide on Youtube on their channel if you want to take a look.

This is interesting. From what I recall, LightBurn checks for installation on VM and prohibits this normally. Based on your description Linux is the guest in this VM scenario. Trying to think if that would cause you any grief in terms of what’s going on.

By the way, it’s not necessarily a problem that LightBurn cannot automatically find the laser. As long as you create the device manually correctly all should be good.

Make sure you choose Origin at bottom/front left and disable auto-home for your laser (unless you’ve added homing switches).

Just to be sure, you can use this command to remove brltty completely:

sudo apt-get purge --auto-remove brltty

I don’t know if it helps, but I also put the procedure for Ubuntu 22 here :Setting up the software - Diode Laser Wiki

1 Like

Thank you for this. I’ve been temporarily pulled away from this task, but took a quick look at your page and I will definitely be checking it out as soon as I can. Thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.