Send to Laser Shortcut No Longer Working (1.3.0)

The send to laser shortcut (Alt+Shift+S) is no longer working after I updated to 1.3.0. I’ve tried remapping to another key combo with the same result, and I can send data to the laser by clicking the send button. I’m running Win 10 Pro to an OMT 100w laser.

I am also experiencing this issue, in Lightburn 1.3.01 running on macOS 12.5.

When I press ALT+SHIFT+S, I sometimes need to press it twice, and then I see the Send button gets focus (the light blue outline). I can then press Space to ‘press’ the button, but this is quite frustrating nonetheless.

Do you use a checklist or have any other pop-ups when clicking Send in LightBurn?

@LightBurn No, nothing pops up.

It might be easier to see what is happening, so I’ve done a quick screen capture: Lightburn Send to Laser hotkey bug - YouTube - Sorry for the jankieness at the end trying to find the hotkeys menu :slight_smile:

That just says the transfer failed. The hotkey itself is obviously working, or you wouldn’t get a failed transfer message.

The original poster is saying that their hotkey isn’t working - your issue is that the send itself is failing, so these are different problems.

@LightBurn the failed to transfer is a red herring - it didn’t send because the laser was currently in use, however the issue with the shortcut still exists.

If you watch the video between 0:01 and 0:05 you will see (with the keypresses shown in the bottom left) that the shortcut needs to be pressed twice, and then the Send button receives focus (which you can see with the blue focus ring), and then I have to press Space to ‘click’ it.

Previously I would only have to press the shortcut (option+shift+s) once and it would attempt to send (i.e. pop up the input box for the name) straight away.