Setting Origin no added controller

I am unable to set an origin point in LB. The home is fine but even if I clear origin, set origin or saved position, as soon as I press go to the laser goes to the lower left corner and out of bounds so I have to emergency stop it before hurting my stepper motors.

I have search but did not find anything that can help!

thanks

Hi, have you set it in ‘Device settings’? top of page (spanner and screwdriver)

Not really, To be honest I do not know the software that much and all these line commandes etc are a little out of my league. Can you point out the settings I have to play with. Thank you Chris!!

I see the 4 dots for origin so I changed that to top right so it won’t go off to lower left on me, but still won’t let me set origin for the start of my project

Perhaps reading the documentation on how to do device settings and the other important information in getting started would help you ‘get into the league’…

Tom, Yes I have read some parts…not all yet, getting there, but I posted here because I could not find why it was not working. When I place the laser in my start position I press set origin so I can come back to that point for the next step. (from what I understood in the docs, it should go back there when you press got to origin) but when I press got to origin the laser scoots off to lower left out of bounds. So, I wanted to know if there was a setting I didn’t get right or something you guys (with more experience would know about)…same thing goes with my other post about the fire button working and then deciding not to work sometimes… anyways this post is about the origin… thanks for all your responses

Also, for example if I set an x and y position and press the “move to” button, it fly off to the lower left out of bounds. So, I might be doing something wrong but can’t figure it out.

What type of equipment are we dealing with?
Does it home on power up?

Shapeoko XL with JTech 7w laser and LB. Homes to top right on power up

Check in Lighburns Edit → Device Settings → Origin is properly selected. If it homes upper right then that’s the radio button that needs to be set.

In the bottom right of the Laser menu is the ‘Job Origin.’ This is where it’s going to start the job. You might want it to scan bottom to top for some reason. You just need to be aware. That should not effect the problem.

Next set, in the ‘move menu’ the ‘Distance’ to some small value. I use something like 10mm. If you click on the right arrow (>) in ‘move’ and see if the head moves 10mm to the right. If that fails, try it again except press the opposite direction. If the first drives you the wrong way, the second will drive it the right way.

At least you’ll have some idea about what’s doing what. If all you controls work in reverse, back to configuration.

Hope this help. Good luck.

Hey Jack
well all check ok, but still if I set origin before the start of my project, if I then press go to origin it keeps coming down to the bottom left out of bounds.Problem seems to be it does not record the set origin.

How this works can be confusing. I still run into it and it goes back to the coordinate system. If your setting ‘Job Origin’ from the ‘dot’ field and you have it set for ‘User Origin’ it could be driven out of bounds.

Lots of things can happen here. Have you gone to the ‘Move Menu’ and tried the ‘Get position’ and other options there?

Do you know what the $10 value of your grbl machine is set to? It needs to report all machine and position data, as far as I know.

Does it ‘frame’ the area to ‘lase’ properly?