SH-G570 Chinese laser machine

Hi ive recently upgraded from the k40 to a bigger machine sh-g570 which I’ve upgraded to the dsp software
it seems the laser is crashing into the side and doesn’t stop I’ve looking in various sections of the lightburn software but im not sure if anything need altering
I’ve tried different things all day i cant even factory reset the board as its pass worded



It sounds like you limit switch may not be. functioning properly. When you power on the machine, does the head go to a corner, stop then move a small distance way?

No it just smashes in to the side and doesn’t stop unless I press the stop button it was OK earlier I did alter the polarity of the x,y axis and the trouble started
I’ve taken a picture of the board it seems the all the axis are on 100000

That’s the problem, why did you alter the polarity? That will change the direction of travel.

Before you touch anything in the controller, make a backup of the settings. You are fortunate that you didn’t reset the controller. These are generic controllers, each manufacturer sets them up specifically for the machine, including the number of steps/rotation and MANY other things that you would have to guess at and probably end up going back to your manufacturer before it would ever run properly again.

Back it up!

Are you trying to get it to ‘home’ somewhere other than where it was setup to home?


Yes I think I will do that in future save alot of hassle


No it’s setup home on top right but the movement axis in lightburn was back to front so I went into settings and inverted them that’s where it started

This is by design, as many laser systems pull the exhaust to the back of the machine. The design is to not draw the smoke back across your finished work. You can flip the fill the ‘Scan Angle’ to 180º to have the job process as you’d like.

You can also change the direction using the ‘Cut Optimization’ ‘Cut in direction order’.

it still doesn’t exactly fix the problem with it smashing into the sides

What exactly did you change?
Did you put it back?


It was when I read on one of the lightburn topics of changing polarity of the axis since then it went wrong only I didn’t make a backup of the old script

I was wondering if anyone could send me their file of settings and I’ll load it into mine

The board is a 6442

Explain in more detail what exactly it does.

When does it hit the frame?
When it’s trying to home?
Running a job?

Do both axes do this?

There is enough knowledge here to help you get it back. Incorrect configuration is the number one problem we all face.

Although these machines look the same they are probably not configured the same.


it hits the frame when starting up for some reason the home went from top right now to top left
i haven’t managed to cut anything as yet
the axis are all x,y,u are all 10000,0
when i click home with in LB it crashes into the left hand top on setup i set it to top right

right ive taken screen shots of my settings hope this helps a bit more

Screenshot from 2021-10-03 07-26-57

Probably the “Direction polarity”. Flip that and give it a shot.
It should have “Enable homing” also.

If it heads the wrong direction, press the ‘esc’ key on the keypad.

DON’T copy mine, just change these two. If it ‘homes’ ok, we going in the right direction.

Your description was it was the X axes. Looks like you’ve turned off a few things…

This is a wider scope of my settings

Notice X & Y are NOT configured the same. Did you change both axes?


I cannot remember if I changed it don’t think I did was just the polarity of the x,y axis is there anything within the control board I could of altered without knowing ?
In the para settings on machine config

I don’t think you could have modified it in any way without knowing it.

Your statement was the X axes. If that’s the one crashing, change only it’s directions, both should have ‘home’ enabled.

Start with one axes, and get it working, then you can move on.

You’ll be a wizard at this when you’re up again. And you won’t do this again…


right its now going to the right hand the correct way its really slow and making a juddering noise

I’ve looked up the laser you have, there is a ton of them, so I have no idea what you have.

It did not come with a dsp controller? What was it?


The dsp controller is the 6442 can use RD works 8