Shaky/flickering image in Windows

I have an 8MP 110degree Lightburn camera. It seems to work fine when plugged in to one of my Windows machines, but on others it stutters and stalls, producing an image with multi-coloured scan lines flickering over it for a few seconds before crashing whatever app is accessing it. Making it unusable for anything.
Have tried multiple USB ports, installing and uninstalling through Windows Device Manager etc. No luck.
The windows machine the camera does work on is probably the lowest specced of the 3 machines in terms of processor, ram, etc.
Keen to hear if anyone has expereinced and solved this issue and how (specific driver, adjusting some refresh rate?? ) I’m stumped.

Image of MDF through camera: just to show the multi-colured scan lines/flicker:

Is this connected just through the supplied cable, or are you using an extension?

On one machine it’s through a separate USBc hub (via the lightburn supplied cable), on the other it’s straight into one of the USB ports on a MS Surface Book laptop with the supplied cable. Both produce the same effect of flickering and stalling.

If it works properly on one machine, it’s probably not the camera. Run Windows update, and reboot the machines. See if that helps. If not, it could be the camera - how long have you had it?

Yes, at first I thought the camera was stuffed after transferring to a diff machine. …and then another machine and both failed. But I’ve now tried it on 4 diff windows machines and 2 work, and 2 fail. Have run Windows Update on all, and in all Windows Device Manager says that “This device is working properly.” and that the latest drivers are installed. …though Windows often makes a habit of saying that things are working properly when clearly they aren’t.
There must be some hardware or software conflict somewhere, but I’ve no idea what it is.

Only had the camera for a couple of weeks, and in that time only used it for calibration and one test run.

On the machines where it’s not working, try this: Go to Edit > Settings, and at the bottom, change the ‘Capture System’ setting from ‘Custom’ to ‘Default’ and see if that works any better. Let me know if that improves or not.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.