Shifted fill + line layer after image layer (intermittent)

I am burning a design with 3 layers: 1. line that was extracted via lightburn form a PNG image, 2. the PNG image which is used to provide some shading inside of the lines 3. Graphics and text (created in lightburn)

that are fill + line.
All show as properly aligned in lightburn UI.
If I run the line layer 1 and the graphics layer 3 , they are aligned most of the time (one example shifted)
If I run all 3 layers the graphics are shifted to the right by about the width of the image.
If I run layer 2 (image) and layer 3 (graphics) the graphics are shifted to the right most of the time (one example was good).
If I run one layer at a time: e.g. layer 2 (image) then cut layer 3 they are aligned
This happens both in direct connect more (which I normally use) and if I send the file to the laser and run from there.
I am running Lightburn 1.0.04 on a PC with windows 11, Laser is OMtech 3555 135w with Ruida 6442G controller.
Attached photo shows the problem with the small arcs (the start of the graphics layer before hitting stop) shifted.
Top left shows all 3 layers working properly (luck on first try)
Bottom left shows where layer 1 and layer 3 were cut together resulting in the arc indicated as try 1 direct. The full circle and slash were a separate second cut to see if they would still align. Both passes were done direct from lightburn
Top right shows layer 2 and 3 in one run where the file was sent to the laser and run from there
Bottom middle was done as 2 separate passes, one with the image, one with the graphics and it worked.
Bottom right was done in 1 pass (direct form lightburn) . This was then used with more text on the cutting board successfully.
If you are wondering about the design it is for a cutting board designated as gluten free for my daughter with celiac disease.

There’s a lot going on here and it’s hard to tell from the samples in the photo but could you be experiencing the skewed engraving problem described here?

Configuring a Ruida - LightBurn Software Documentation

This is related to stepper PWM detection at rising edge vs falling edge.

A lot of what you are doing can be conveyed to us via the .lbrn2 file. It helps us understand your work flow, at least at the lasers end…

If it’s not a proprietary issue and you can, it’s helpful to post it.

Is this something new you are experiencing or you just noticed it in some way?


Thank you for the replies:
I should have said this is a test card where I was trying to dial in the layer values. There is just one copy of the wheat and the circle slash plus the words “GLUTEN FREE” on one end of each cutting board face.
It is not the rising edge / skew issue. The fill + line on layer 3 (and other projects ) works just fine with the fill + line of the same layer lining up perfectly even for very large engravings. Squares and circles measure perfectly whether fill and/or line.
So far it is just this project. However it is also the first time I have used the lightburn tracing feature and had an image as one of the layers.
Here is the lightburn file:
gluten free+wheat stalks.lbrn (1.1 MB)

Are you setting the selected layers on and off via the ‘output’ in the cut/layer gui?

Or do you select the layer and ‘cut selected graphics’ and send it to the controller?

What is your ‘Start From’ and ‘Job Origin’ settings?


This is making a lot more sense to me now after seeing the .lbrn file. So this is fundamentally a multi-job alignment issue. But one line from your original post is confusing me:

Are you saying that only the 3rd layer is shifting? Or the entire burn is shifting? If the former then not sure, if the latter then some possible answers.
Which burn example is this one?

The file is showing Absolute Coords, is this how you’ve done all these runs?

Yes I have been using absolute coordinates (I just checked this and several other files). I have been using the lightburn camera a lot (since I got it a few weeks ago) and aligning the graphics as a complete group to the photo overlay. When everything works (which is all of the time except for this file), it is so very easy to align the graphics to the work surface.
With this file it is just layer 3 (circle/slash + text) that is shifting. The other layers are right where they should be. In the lightburn file you can see I have turned off the image layer to get successful runs on the cutting board with just the first and 3rd layers.

Hmm… if you are using Absolute Coords then the only thing that I can think of that would be happening is that you’re somehow losing steps.

Your fastest layer is running at 600mm/s. That seems really high to me but I’m not familiar with your laser. Is it possible that you’re overdriving it and thus losing steps? Do you hear any whining or complaining from the steppers when this is running?

Is this the same speed that you run other jobs?

Perhaps you could try running the whole thing slower to see if you get different results.

I had imported cut settings from my library for similar materials and probably should have set the speed lower as it really is never seemingly hitting 600 on the layer 1 line art. There is no shift in the line art that would indicate skipping / missing steps. I built my CNC router and 3D printer and am familiar with the skip step sounds and results.
Additionally if I run layer 1 &3 as one job then everything is aligned. If I run a job with layer2 enabled (1+2+3 or 2+3) then layer 3 is usually shifted. If I run 1+3 (layer 2 output disabled ) or run 1 then run 3 then things align properly.

The thought process was that I could see a scenario where the initial acceleration necessary to get to a certain higher speed would cause one set of layers to skip while subsequent runs do not, or skip at a different rate. This could result in the whole set of layers in that run to be off.

But based on what you’re saying about being familiar with this sound and that you’re been using these settings for other jobs then we can rule this out.

Are these behaviors perfectly consistent? So if you run in these combinations the results are always the same?

If I’ve done my accounting correctly I think you’re saying it’s only the presence of layer 2 in combination with another layer that causes an issue. And the issue manifests not on layer 2 but in layer 3. Wasn’t sure if layer 1 was ever affected. Can you confirm this understanding?

Can you confirm one thing? You’re explicit on which layer is shifting. Are you saying this in absolute terms or relative ones? Meaning, is the layer shifted with respect to the actual bed location as per design? Or is it shifted just relative to the other layers? Trying to understand if the “aligned” layers are actually potentially both offset by the same amount.

This one is a bit of a headscratcher.

I assume that the shifted layer is shifted in absolute terms as well as relative to the other layers. The other layers are cut / burnt at the position that would be indicated by the alignment via the camera to the piece. I did not do a post cut camera alignment double check in this case but had done so in the past, where I mark where the piece is to be engraved / cut, note this on the camera image. Overlay the graphics in lightburn, make the cut / engraving and then capture a new image of the engraving which has been so far perfectly overlaid with the graphics in lightburn.
To me, this “feels” like a software issue. I would commonly “break” the software (testing as a product manager) my engineering team had just finished as I would often use a difference sequence of events than they had assumed. However, I have not run an extensive set of test cases, but this “seems” related to having the image layer ahead of the line +fill layer in the sequence of steps to burn. I did at least eliminate the common issue of direct burn vs send to controller then run / burn.

When selecting what to cut I have been turning the layer output on and off vs selection via the mouse.

I follow your thought process but feel this is unlikely at least on the LightBurn side. Your design setup doesn’t seem unusual or peculiar in any meaningful way. Fairly mundane really that I’d be surprised if this had never come up for anyone before. Can’t rule it out of course.

I hadn’t asked before but should confirm. I assume the Preview for all these burns looks correct?

One thing maybe to try is to write the RD file for a known “bad” burn to disk. Then import that file back into LightBurn. Will give you an idea if the instructions are at least correct coming out of LightBurn.

Also, do you have a screen on your laser that gives you a preview of the burn? Do things look correct there?

The lightburn preview looked correct (I viewed it multiple times fighting with an endpoint connection to the circle on the slash). I do not recall if the preview on the laser looked correct (I hardly ever use that method). I will need to check tomorrow. How do I pull the file back from the controller to lightburn?

I’m not sure if you can pull the file back from the controller. However, in the Laser window instead of the Start and Send buttons, there is a button called “Save RD file”. Use that to save the file.

On the return trip you should be able to import or open the RD file in LightBurn. Not sure how well that feature works but you should be able to at least get the path shapes back. Not sure about the image.

I just tried 6 times in varying combinations to reproduce the problem. I cannot get it to recur :unamused: I tried both the latest version of the file and one of the intermediate saves (before adding the text). In all cases it turned out correctly as burnt and when I sent to the laser. the previews were also good both in LB and on the laser(but not conclusive since I cant reproduce the problem now).
Thanks for your help.

Oh wow, that’s maddening. Don’t worry. I’m sure that little demon will come back when it’s most important.

Take care.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.