Show last position

OK, when I click on “show last position” the indicator icon is completely off the grid area, when it should be exactly in the middle of the grid?

What kind of controller / firmware is “DIY”?

image

Assuming GRBL, you likely have a workspace offset programmed, but have the system reporting in machine (absolute) space, not workspace. Depending on the GRBL version, you change this with the $10 setting. For GRBL 1.1f, it’s $10=0 to report in workspace. For GRBL 0.9, it’s $10=2 (I think…)

1 Like

OK, using keyes controller, grbl 1.1, have tried everything to correct the position of the laser on the workspace, so far hasn’t worked. Am attaching a diagram of my problem, thanks for your help.

“I have tried everything” - it would be more helpful if you could tell me the details of what you’ve tried, so we can eliminate those.

In the console, type $# and press enter, and post the response from the controller here. Then, type $$ in the console, and post that too.

If you normally use your machine as a CNC, it’s common for them to use workspace offsets that change. In LightBurn, you usually set the origin to the front-left by jogging there and zeroing, then set the controller to report its position relative to that point.

Does your machine have homing / limit switches?

Have limit switches, not homing, here are my settings, note $10=3 is the last setting I tried.
LP:$$ $# $G $I $N $x=val $Nx=line $J=line $SLP $C $X $H ~ ! ? ctrl-x]
ok
$$
$0=10
$1=25
$2=4
$3=7
$4=0
$5=0
$6=0
$10=3
$11=0.010
$12=45.000
$13=0
$20=0
$21=0
$22=1
$23=0
$24=25.000
$25=500.000
$26=250
$27=1.000
$30=1000
$31=0
$32=1
$100=100.000
$101=300.000
$102=255.000
$110=1250.000
$111=1250.000
$112=1250.000
$120=40.000
$121=45.000
$122=45.000
$130=500.000
$131=500.000
$132=500.000
ok

Based on the official documentation for your firmware: https://github.com/gnea/grbl/wiki/Grbl-v1.1-Configuration#10---status-report-mask

This was pointed out above.

And you have not answered the questions posed or provided the information we request. Please don’t make us ask again. We do want to help, but you are part of equation, we need your answers to do so.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.