"Showing Last Position" Incorrect

Hey guys,
Sorry if I’m in the wrong place, first time here.
On an X-Carve with a Jtech laser, right after I home the position shows correctly at 0,0 in the bottom left. As soon as I move the machine, the “show position” jumps to the top right out of bounds of the machine. If I jog the machine moves correctly but doesn’t update correctly on the screen.
Set Origin, Clear Origin, do not affect the position onscreen.
Tried reinstalling Lightburn, GRBL should be up to date, Picsender and Easel are still working normally. In only Lightburn the machine does not want to move correctly. Guessing I have a setting flipped or something somewhere and cannot find it.

Any ideas would be great.
Thank you!

Read here - this addresses the negative coordinates used by XCarve and other common CNC systems, and how to use an offset to fix it: https://github.com/LightBurnSoftware/Documentation/blob/master/CommonGrblSetups.md#common-grbl-setups

While not specifically for the XCarve, this is a good general setup procedure resource for the JTech gear. And, Try setting $10=0 - I think the JTech article is still missing this.