Size wrong when cutting on co2

Hi, when I open an .svg file in Lightburn, it’s just a circle and shows 4.6028 in for width and height. When I cut it on the laser, it comes out closer to 3.6". I’m sure I’m missing something, but hoping someone can help me locate the setting.

Ruida controller, OmTech 1624-55 Laser.


Is this unique to SVG or do you have a size mismatch for anything in LIghtBurn?

What happens if you burn a 100x100 mm square? Does it come out dimensionally correct? If not then you likely have a calibration issue. Check Axis Calibration in Machine Settings.

I’ve never tried anything except SVG’s. Let me create a square in Lightburn and see what happens.


The ratio between those two sizes is just about 72:96, which suggests the SVG was created with 72 pix/inch and LB is inhaling it at 96 pix/inch.

Edit → Settings → File Settings → SVG Import Settings

May be your friend …

Thank you, that was it exactly. After I changed it to 72dpi, opened the same .svg, it cut exactly the correct size. Do most people design at 72dpi or is that something you just need to figure out each time?

The measurement in LightBurn should still match the output. The 4.6028 in circle was pre or post import?

When I imported the svg into LightBurn, it was showing 4.6028, but when I sent it to the laser, it actually cut it at about 3.6". I also created a 3" square in LightBurn and sent it to the laser and it cut at the correct dimensions.

That’s the part that’s throwing me off. Usually cross-DPI issues would show up as a difference between expected size and size in LightBurn at import time. It wouldn’t show as a difference between LightBurn design and output. What you see on screen should be what you get in output.

So this one’s a bit odd for me. Unless I’ve just missed something.

Yeah, it’s confusing to me, but when I switched the svg import setting in LightBurn from 96 to 72 and imported the same file, it showed the same dimension in LightBurn as it did before, but this time it cut the same dimensions showing in LightBurn.

Can you upload the .svg file here? I’d like to experiment with it. I may have misunderstood how that works.


Here is the file.

Thanks for uploading.

I get different results from you. I should have asked you earlier. What version of LightBurn are you on and what OS?

Results of importing at 96 and 72 DPI respectively:

Windows 11, LightBurn 1.2.01

Crazy. I’m running the same. Thought for sure you must have been on an older version that handled this differently. Scratching my head on this one…