Skipping Lines and Constant Power Mode

I’ve had this issue where an intensive vector graphic has sections that skip lines. If the entire graphic is one layer (03, for instance), I often get one or a couple of lines that would skip. If I turned that skipped line to another layer (04), it would then burn that line, but then a different line would skip. It was getting frustrating.

There is nothing in the coding that would explain it, it simply stated “Starting stream” and “Stream completed”. The laser would move through the motions, but only the beam would shut off for that particular line or line segment. Often times, on subsequent burns, the same line would skip.

So I tried something else today, and I have often converted some of my vector graphics to separate layers to avoid the potential skips that have plagued both my machines for the past year. Today, it was a Celtic knot, and while it’s complex, it’s a vector so it’s nothing out of the ordinary, just lines. And of course, it skipped on all layers - except one of them. That one layer that didn’t skip has been my go-to layer when my default choice layer for lines starts skipping.

So, along with a friend, we did some testing and between the two of us (mostly him) we discovered something: the lines that skipped were each in Constant Power mode. Why would that matter? Well, the layer that never skipped at all was not in Constant Power mode. One layer had a Kerf Setting that I missed, but again, why would Kerf turn off the laser beam through a portion of the burn? We use kerf for cutting, and the only difference is placement of the line, not whether it actually turns the beam on or off.

Yesterday, I did 9 burns using these same layers and not one line skipped through any of those 9 burns. Today, I imported a graphic into that same file, and immediately lines began skipping. So is importing an Illustrator graphic causing it? Who knows… I imported Illustrator graphics to create the file in the first place and it didn’t skip.

In the graphic below, the layers are numbered to match what is in Lightburn. I have the file saved as my original test (four layers and a Tool line) and then a second “default” test where I “Reset to Default” on those three layers that had Constant Power Mode, and voila! No more skipping.

On the surface, that Constant Power Mode didn’t throw up a red flag before because it’s not something that you think would randomly shut down the beam during a burn.

So if Mr. Lightburn is interested in looking further into these, let me know and I’ll share the files.

I guess no interest/concern?

Or lack of insight in my case…

Based on your description I don’t see how this would occur other than a fault in hardware. But you’re saying that the issue is unique to this file. The source of the graphic is almost certainly not related to the issue.

Can you upload the .lbrn file to take a closer look?

I never stated this is unique to this file at all, as I mentioned I’ve been struggling with this for a while now and had no luck figuring it out. But I sent the file to another person who ran it and he had the same issue on his machine, so it doesn’t appear to be hardware related because we could duplicate it.

But the point I was making with this post is that we finally figured it out, at least it was a solution to the dilemma, but didn’t seem like it should be a “fix”. It seems that the only “Line” Layers that were skipping on both machines were set to “Constant Power Mode”. As soon as I de-selected Constant Power, then all lines burned completely. Again, this was tested on two different machines, and the underlying factor was that Constant Power Mode was selected.

Perhaps Constant Power Mode is not necessary, but my understanding was that this feature was added to improve burn quality with regards to variable power and changing directions. Unfortunately, it has been causing lines to skip entirely - sometimes in the middle of a line segment, meaning, occasionally a line that is an inch long will have a skip, or sometimes it won’t burn that line at all.

I misunderstood your explanation that this occurred with the Illustrator import after 9 successful burns.

Can you confirm the specific model of laser you have? You list OLM2 Pro but want to confirm this is not S1 or S2. And the other person testing with you has the same laser?

Have any modifications been made to the machine?

This is the opposite actually. Constant power mode actually disables variable power which is what makes the symptoms even more odd. Constant power mode would normally give you constant laser light irrespective of speed.

Are you able to upload the .lbrn file that was used in the photo example?

Both machines were OLM2 Pro, mine the S2. I had said that I did several other burns and they were successful and then it reared it’s ugly head, but at the beginning I had stated I have had this issue with this happening. I’m just trying to illustrate that it’s ongoing, but not happening on every burn that I do.

Regarding constant power mode, regardless of my interpretation of it (which I copied from a light burn explanation) nonetheless, it seems odd that Constant power mode would make it skip random lines.

I’m not sure what you feel that you may find by having the file; the coding doesn’t reveal that there was anything out of the ordinary. Since I have found that turning off Constant Power Mode it seems to be working normal and I no longer have the skipping.

I really don’t think it’s anything in the file, because it’s done it on multiple different files at varying times. Sometimes it’s always the same line that skips, other times it will pick another line to skip, but it was only happening when Constant Power Mode was checked.

I agree. This seems to be the unexplained portion and counter to expected behavior.

The idea was to review the design for something either in the design itself or in settings that could explain the behavior. This also allows for experimentaion. If you’re content with the outcome there’s no need to explore further.

What are the speed and power settings for your line marking and what are the Machine Settings. Open the Console window in LightBurn and enter the following:
then press enter.

copy and paste that into a reply here.

An overspeed condition between fast travel and engraving can cause power to be pulled in some of the motion controllers.

Changing layers may cause that behaviour to move around and constant power will mask the behaviour but i’d like to see what the speed and acceleration numbers (and units) look like.

Actually, the speed was not very much at all. It was at 550mm/m and 20% power. I kept it slower just because of the intricate pattern I was burning; I didn’t want to have squiggly lines from moving too fast where it transitioned from one direction to another in a small area. The pattern I posted in the image above was on a light switch cover, for size reference - not very large graphic, but a lot of lines.

At any rate, I had three layers that were Constant Power, and one that was not. The three would skip nearly ever job. The one would never skip. When I had noticed it skipping on a very intricate job with a lot of lines, I changed the skipped lines to a different layer (that was, subsequently, not Constant Power) and then the original layer would skip in a different area.

For example, I had one burn that was about 60 horizontal lines (Layer 03 - CP). The 8th line up would skip partially, so I changed the 8th line to a different layer (Layer 04 - same settings but not CP). Next time, the 9th line would skip. So I changed all 60 lines to Layer 04 and nothing on the job skipped after that.

Well, the problem with this is “Constant Power”. I’ve run multiple jobs and have turned it off and nothing has skipped. Then today, something skipped, and I checked the layer, and I guess Lightburn remembered that layer being Constant Power, and it was checked, most likely because I was checking values on a different file and neglected to go to that layer (03) and turn it off. So, I’m sure nobody wants to hear this but Constant Power is the problem. Not my file, not my machine (someone else’s did the exactly same thing), and not the complexity of the file. In every case where it skipped, Constant Power was checked. So I guess take it or leave it, I won’t be using that feature anymore.

Check this out. Gil talks about a firmware bug related to constant power. I’m wondering if it’s related to this issue.

1 Like

For some reason, I can’t seem to do a direct reply… habits. lol

I had another issue that might have been somewhat related to that, but since I had so many issues I given a link to a firmware update, and it still persisted. The old problem, which hasn’t reared it’s ugly head, is that the laser would move to the starting point of a job (whether it was a line, fill, or just framing) and instead of completing the task, the laser would come to a stop, and attempt to complete the job in that one spot. The laser module burned, but didn’t move until that ‘job’ was done and then the module would return home.

However, this issues is virtually the opposite: the laser moves through the entire job, but in some parts of it the beam shuts off, then turns back on to complete the rest of the job. This could be one line, or a couple of lines, either connected or not. In any case, this latest issue seems to be a conflict with Constant Power, whether it’s software, firmware, or hardware related, I don’t know… I do know it has done this on two different machines, with two different firmware versions, both running lightburn. Both machines, however, are Ortur, so for now, turning off Constant Power has resolved it for me.

@OrturTech Gil, could you take a look at this and see if this is the same Constant Power Mode bug you were referring to in the other post?

Just an FYI… I posted this and the other one on the Ortur forums, and basically got the standard, “belts are loose”, “loose wire”, and “lens is dirty”, none of which would cause the exact same line to skip in three consecutive burns, on different days. lol

It is possible is a bit hard to tell without
a) Toggle on off
b) Read the Gcode
@MascotGraphics can you do a $i in console and post maching output please?

That was the problem with this skipping… there were no error codes at all because the laser was going completely through the motion of the burn, it was just shutting down the beam part of the way.

When I looked at the code to see if there was an indicator, it only stated:
Starting stream
Stream completed in [time]

There was nothing between those two lines. A couple people have said that there has to be something in the code, but there wasn’t.- the laser followed the entire path without deviating, it was only the beam that shut down.

So just to confirm - turning off Constant POWER off machine performs as expected

Any chance you could do the $i for me please?

Yes, I had the skipping issue quite often, but once I turned off “Constant Power” I haven’t had the skipping issue since then.

Paul tested the file on his own machine and it was also skipping lines. He is the one who alerted me to the lines that skipped were set to Constant Power. I’m in the middle of a job, and this was about 10 jobs ago, so I will try to run that later today, but I am now on the LM3 and don’t have my LM2 Pro connected, but will see if it happens on the LM3 as well. thanks

Paul just ran my test on his machine, with is an Aufero, and it still skips, and this was the code from his console. The top burn was one layer with Constant Power off, the test was below it with Layer 2, 5, and 3 skipping and had Constant Power on, layer 4 (40%) did not have Constant power on and did not skip.
Starting stream
Layer C02
Layer C03
Layer 40%
Layer C05
[MSG:Pgm End]
Stream completed in 1:54
[ORIGIN: China]
[MODEL: Aufero 2 S2]
[OLF: 187]
[SN: 69BD98CA39B100EC70BB2F1D75C8E226]
[DATE:17:16:25 - Dec 15 2021]
Target buffer size found

Thanks trying to replicate
This helps!