Slow software processing time

I’m trying to fill a 1ftx1ft area with 50-500um diameter circles. I start with one small circle, then use array to get as many as i can. I encountered some issues:

  1. The array is capped at 200rows x 200 columns. I need thousands x thousands.
  2. When i copy paste 200rows x 200 columns, the software freezes for a few minutes.
  3. I need to offset fill the circles. Even if i use virtual array, it still takes forever to calculate offset. (I need offset fill because i don’t get perfect circles with cross-hatch.)
  4. I looked at my PC’s performance, only 6gb RAM is used. Also, CPU is only ~25% utilized. Does that mean Lightburn only uses single core?

File size i’m handling reached 250mb when the 1ft x 1ft area is fully filled with micro circles.

I have 64-bit Windows 10, 16GB ram. 4-core (8 logical processors) i7-8665U CPU @1.9Ghz.

What can i do to speed processing time. Please advise.

Hi Rembrant,

Is there any particular reason you can’t use the outermost circle and JUST offset fill that one?

If you fill a circle with circles and offset each you will go way behind the capabilities of what lightBurn was designed to do - and probably what any laser can really render.

Maybe I am missing the end goal here could you explain what you need achieved?

Visuals would help greatly.

2 Likes

I don’t think we can make your machine run faster, but if you give us some clue as to what you are doing, we might think about handling it differently …?

What are you doing over such a large area with 40k + super small small circles?

I have no clue as to what the job time on this would end up being… Do you?

:smile_cat:

You said “when I use cross-hatch I don’t get perfect circles”. Can you be more specific?

Offset Fill is very processor intensive and is not advisable for this number of shapes. It would be much simpler for you to just manually draw the number of “nested” circles you need, and put those into a virtual array, or just figure out why normal fill is not giving you what you want (likely incorrect timing settings).

Thank you all for the fast response.
I’m trying to achieve something similar to the image below:
image

So in my drawing, i have a circle set at 180um diameter. then use grid array to generate a grid of circles evenly spread over an area of 300mm x 300mm.

Then i use virtual array on all circles to generate the perforation pattern.
At this point it becomes so laggy.


Is there any way to overcome the lag issue?

I tried to engrave a smaller size 100mm x 100mm to check the engrave quality.
When i use crosshatch fill, each engraved hole has a polygon shape, almost hexagon or octagon. it’s fast, but not a circle.

If i use offset fill, each hole is a circle which is what i want, but really slow to calculate.

I tried 3rd approach, where i have a circle, then i have a crosshatch fill and a line fill. It’s faster and it gave me a circle.

The virtual array works for rectangular shaped materials. But in the future, i will need to make the same perforation pattern on non-square materials. For example, i might perforate a 12in metal disc. How do i limit the perforations pattern to that shape?
I’m aware of the cut shape function, but the software freezes when i try to cut out that many micro dots.
Please advise. Thank you.

I have a way of mitigating lag on already made drawings.
When the pattern is complete, i “unshow” the layer from Cuts/Layers.
But i still lag a lot the first time when i try to create the patterns.

If there’s any way to make the designing step faster, please let me know.
What PC hardware can i upgrade that would have the most improvement?

Please advise. Thank you.

Honestly the best way to produce this might be an image. The problem is that the software has to draw the circles, hundreds of thousands of them, individually. If you used a paint program to produce the grid of circles, you could load that as a single image (or an image tiled a few times) and that would be much faster, though you’d only get the option to raster fill it.

For the curve quality issue, go to Settings, click ‘File Settings’, then check the “Output Curve Tolerance” value in the lower right. For galvo work that should probably be about 0.025mm, possibly even 0.02mm. The default is 0.05mm for diode and CO2 systems. That controls the level of curve subdivision when outputting to the hardware.

LightBurn is mostly single-threaded and doesn’t use graphics hardware, so the best improvements will be a better class of CPU, higher clock rate, and more RAM.

And honestly a “normal” array will likely render faster. Virtual array used two color dashed drawing, which requires two passes over everything. Drawing real copies of the shapes only makes one pass, which will be faster.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.