Software crashing on Mac (#2)

I am attempting to use Lightburn for the first time with my K40 machine with a Cohesion3d Laserboard installed.

When the application launches it attempts to scan my machine which is plugged into my MacBook Pro via USB and crashes.

I can’t upload the crash log because I’m a new forum user…

I’m unable to move past this first step. Have tried rebooting my computer. Reconnecting USB etc…

Mohave 10.4.5. MacBook Pro (15-inch, 2017). Lightburn

Close the auto-finder and choose “Set up Manually”. Add a device called Smoothieware (the C3D default) and go from there. The origin is front-left. That should be all that’s needed.

Thanks. Just did that. I doesn’t seem to be able to find my board. I do not see the board in the connection dropdown. Nor can I move the machine on (auto).

Do you have the SD card in the Laserboard? It’s possible you need a driver installed for it, but I’d have to double check that.

According to the Smoothieware docs, you don’t need a driver for the Mac.

Oh my… I’m feeling dumb. SD card was not in the board. Thanks! Still not sure if that would fix the crash I was having though… But manual setup works now.

I need to get a Mojave system set up. I haven’t been able to reproduce this crash, but I’m on an MBP that’s still running High Sierra. It might be related to the new OS.

Happy you’re up and running. :slight_smile:

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.