Software Lagging The More I add to the work area, the slower the software goes

I try to use my entire laser Bed (1300 x 900) to economize on time but when I fill up the screen with engraving and cuts the software lags so much I can almost write this post while I wait for it to catch up. Is this a Ram issue? (I have 16 g, 6 core 3.8 GHz processor) or could this be a graphics card issue? I love the software but it’s slowing me down when the workspace gets full.

This is highly unusual. Is this something that’s come up recently or it’s always worked like this for you? I suspect there’s something unique or unusual in your designs. Are you able to share the .lbrn file here? We can see if others get the same behavior.

If you aren’t comfortable posting the file here, email it to and we can take a look. Include a link to the forum post, and just make it attn:Oz and I’ll have a look and figure out what’s happening.

Ok, My file is 17 Mb so it won’t upload here but I sent it to the email you gave me att OZ. I use the grid array because I’m burning a lot. I Hope you can help me solve this. Thank you in advance.

is there a way to make the software utilize more cores or threads available on the newer processors?

I’d characterize 17 MB as quite big. I hope that’s not .lbrn2 which has improved space efficiency. I suspect you either have an extremely high node count or a large number of very high resolution images.

@LightBurn, please post results of your findings here once you’ve had a chance to look at the file. Always good to learn something new.

Oz and I have been reviewing this file and you are on to one of the issues we encounter. There are a lot of nodes in that file. Quick look shows about 27.5 million nodes. Further results to follow.

1 Like

Your file contains 27.5 million points and line segments, which is pretty insane, and not at all necessary.

When I selected some of the text, I saw this:

Each of those dark squares is a node (point). Even with just two strips of the names it’s sluggish, because there are about 3.5 million nodes here:

Before progressing, I would’ve been asking myself why, given that this feels pretty abnormal.

Doing a pass over these two strips using Edit > Optimize Shapes, I’ve taken it from 3.5m points down to about 220,000, which is much more reasonable. I’m not sure what tools you used to create this file, but it is not efficiently built.

I would go back to the initial original pieces you used, use the shape optimizer on them to reduce the node count, then assemble them into the final arrangement you need again.

1 Like

Those nodes are so dense it almost looks like a fill layer. :scream:

Thank you. It looks like I have a lot to learn. I’ll optimize my images. I created them by Tracing and building them in illustrator and then I exported as dxf for rd works, the dark closet that was my home before I found lightburn. It’s hard to design in rd works so I laid everything out in illustrator and outlined it and exported. But there were a lot of nodes. I am very new to LB.

It’s possible that you may have better luck importing the Illustrator files directly into LB instead of going through DXF as that can create other issues.

I’ll try that, thank you. I appreciate your help so much. I believe I’m sticking with lightburn forever. My next challenge is getting my second head to operate but I think I noticed a thread on that.

Exporting as DXF was almost certainly the issue - If you export as AI or SVG it will preserve splines, but exporting DXF from art software almost always creates tiny lines because they can’t convert to the curve format used by DXF files.

For the 2nd laser head, go to Edit > Device Settings and turn on the ‘Enable Laser 2 controls’ toggle switch:


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.