Software not communicating with hardware

Hello, I’m running a sain soft 3018 pro with engraver and laser. For some reason light burn and the hardware aren’t communicating. I’m running windows 10 and using com port 3 which works for the engraver. When I start light burn the hardware will make some noise and that’s about it. Please help.

There’s really not a lot of detail to go off of here - it would help if you can provide more details, pictures, screenshots of your LightBurn Window, and a video of the issue happening.

Do you see anything in the console when it connects? When it makes some noise, that would generally indicate some communication - it might be trying to home - does it have limit switches?

Ray, sorry about the lack of details. I tried the wizard and that didn’t work. I tried a manual setup and that didn’t work. Using GRBL for device. The only selection for port is auto which didn’t work with the carving software. I think that might be where the problem is?

I think if I could select port 3 it would work. Auto didn’t work for carving software had to select port 3 to work. Thanks for helping…

Ray, OK I’m up and running. Had wrong cable plugged in… Ughhh… Sorry about that. Just trying to figure out how to turn laser off. I saw some topics about the generic GRBL running all the time. I’m not sure what I need to do to upgrade from that so it will turn on and off with G0 commands?

As a starting point, check the settings listed in the “Short Version” listed here:

Those are the most common things that people get wrong when using a CNC device with LightBurn. Check those, and if that doesn’t help, let us know.

I’ve got it running now thanks!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.