Some problems with starting point

Hello, thanks a lot for your work) That’s cool forum and good support – did not expected for 40$ program) I’ve searched for similar problem, but did not find the exact thing. I am using LB about half of an year and it is best soft for my laser, but recently, I did not mentioned, maybe 2-3 updates ago, my starting point started doing something strange) I have ‘‘Start from User Origin set’’, (I’ve tried different options too) but, if check in a preview, it is starts from absolute chords… The strange thing is that week ago it worked only some times. One files, I’ve imported started to cut from green dot, but some do not. But today every restart, every next file it is generating Gcode from red dot. So I have to move my files to attach green to red dots)

I am generating gcode, sending it to another PC, and from there sending it to GRBL board by serial. LB is starting from wrong point, I don’t know how to fix it…

It’s not too much work actually, and thanks for libraries) But it was faster to me to just dropping files without aligning them to start chords. :*

The preview currently shows cuts starting from the machine origin no matter what. (I’m changing this right now)

Can you explain what you mean by “some files start at the green dot, but some do not”? The green dot shows the location of your laser head before you start the job. It’s not necessarily going to be where cutting actually starts from - for example:
In this case, it’s not possible to start the cut on the green dot - The laser would always have to move to the circle before cutting.

If you can show an example of what you mean, it will help. Also, if you’re just going by what the preview shows, it lies. :slight_smile: (though, as I said, I’ve just fixed that)

I know, check this. The thing is that when monitor showed this line, the laser did actually started from this point.
I did not get the point why, but some files usually dxf from solidWorks, started normally with more chance rather than .AI files. (But now it doesn’t)

You have the system set to ‘User Origin’. What coordinate do you have your User Origin set to? If you’ve never changed it, the default is the machine origin (the red square).

Have you read this?

Yes, I’ve read this. I tried both: User Position and Current position, both starts from absolute chords…

The preview always starts from 0,0 (though I have changed this for the next release). The actual job should start from the correct location. Try using the Frame button to see where it is going to place the job - that should be accurate.

Ok, I’ll try it in minute.

Yeah, it is actually works, thanks)

Ook, maybe again something doing Wrong?

EX.lbrn (1.7 MB)

I saved the GCode and ran it through an online simulator and got this:

That matches the LightBurn preview almost exactly. Try saving your gcode and running it here to see if it’s the same:

Maybe my export GCODE settings are wrong?

Your simulated result looks identical to mine. What is it exactly that you think you see that is wrong?

No-no-no, check the lines crossing 10 sign. There real laser is moving to starting point and back.
And check this. I’ve got it today.


Rex.lbrn (1.6 MB)

This is exactly what I was talking before: this is one file, one for all the parts, but one of 7 gcodes exported with wrong starting point. And it is keeps exporting this way.

I have the file, but I need you to describe for me very clearly how you are getting the problem to happen, because I am not seeing it happen for me. Not saying that you’re wrong, I just haven’t been able to get the result you’re seeing, which means I can’t figure out what’s causing it.

I see. Maybe the problem is in my settings… As I told, It is happening some times. Check my settings.

What else can I tell you?

Show me what your Laser window shows, and your Optimization settings.