Something wrong when starting job

Hello peeps, I’m facing some problems with my laser engraver (TwoTrees TTS-55). When I start a job, the machine moves a little bit and then stops without engraving or cutting the design. This is what’s console shows:

Sarting stream
Layer C00 Pass 1 of 4
Layer C00 Pass 2 of 4
Layer C00 Pass 3 of 4
Layer C00 Pass 4 of 4
Stream completed in 0:00
[MSG:X  Axis Standard Stepper Step:I2SO(1) Dir:I2SO(2) Disable:I2SO(0) Limits(-300.000,0.000)]
[MSG:Y  Axis Standard Stepper Step:I2SO(5) Dir:I2SO(6) Disable:I2SO(0) Limits(-300.000,0.000)]
[MSG:Laser spindle on Pin:GPIO(22), Enbl:None, Freq:1000Hz, Res:16bits Laser mode:On]
[MSG:X  Axis limit switch on pin GPIO(36)]
[MSG:Y  Axis limit switch on pin GPIO(35)]
Grbl 1.1 ['$' for help]
[MSG:Local access point MKS_DLC started, 192.168.4.1]
[MSG:Captive Portal Started]
[MSG:HTTP Started]
[MSG:TELNET Started 23]
Grbl 1.1 ['$' for help]
ok
[VER:1.1.2021051202:]
[OPT:PHSW]
[MSG:Using machine:LKS TTS]
[MSG:Mode=STA:SSID=:Status=Not connected:IP=0.0.0.0:MAC=B8-D6-1A-2E-82-74]
[MSG:Mode=AP:SSDI=MKS_DLC:IP=192.168.4.1:MAC=B8-D6-1A-2E-82-75]
ok

What i’ve tried so far:

  • Changed USB cable (3 times)
  • Recreated the device profile on Lightburn
  • Changed configs on Machine Settings
  • Changed firmware (TwoTrees support sent me via Whatsapp)
  • Mess arround with random layers configs

Any tips?

2nd last msg line tells you it has lost connection to the computer, the most common solution to this is to turn off every sleep setting ou can find for when it is not using battery.

Already tried that and the problem still happening. I’ve discovered one thing. If I try to start a job with 50% Power seems to go well, but above that it stops.

Bingo! It’s a hardware problem.

I’d expect the wall-wart power supply can’t deliver enough current for the laser, so high duty cycle cutting “browns out” the controller enough to reset it, or the additional power drawn by the laser produces enough interference to reset the controller all by itself.

The fact that the machine may have the stock power supply from the manufacturer seems largely irrelevant, as many of these machines operate on the ragged edge of failure.

The Amazon listings have a bewildering variety of laser heads with no real description of the input power requirements. If you have a “5 W” laser head and a 12 V wall wart, the laser will draw maybe 2 A all by itself. The motors will draw another couple of amps, so if the wall wart isn’t rated for maybe 5 A or so, there’s the problem.

1 Like

Nice, gonna to test different wall inputs and update here. Tks @ednisley.

Update: Right on the spot @ednisley … changed the power supply for a different one with 5A and seems to be all good. Tks again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.