Speed and Power Troubles

On my Cuts layer, I’ve changed inch/min speed and laser % power on the same object several different times to see results at different speeds. Each time I run the laser on the cut, it still runs at the same speed and power.

What am I doing wrong?

I see from your profile you have an XCarve. What version of your firmware are you using to drive the system? Grbl (1.0c) does not support the variable power (M4) command, meaning you’ll need to use the ‘Grbl-M3 device’ in LightBurn. Grbl 1.1f, will work with the standard ‘Grbl device’ in LightBurn if the following settings commands are entered in the console:


These two lines set the spindle max value ($30) to match LightBurn and Grbl’s default setting (1000), and to enable laser mode ($32).

Thanks for that info. I’m using 1.1f so I will try those commands tonight. I would be shocked if it was that easy and, at the same time, forever grateful if it works.

Rick, your suggestions worked well. However, using 1.1f Grbl jteck 3.8W laser works well. However, twice now it’s stopped right in the middle of a job. No screen savers, nothing to trigger it from the computer. This is the second project this has happened to me on using Lightburn. Never happened using UGS. Not sure what this could be.

Did you get any messages in the console? I might look into USB sleeping in the OS, USB cable, electrical interference/grounding. Maybe others can also offer suggestions.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.