Start and end point of circle don't meet with Lightburn


after using my laser cutter with RDWorks for a while, I wanted to switch to LightBurn. The usability and the camera features are awesome.

But there is one thing, which prevents me from using LightBurn.

I tried to cut some circles out of plywood (same settings and same dxf as in RDWorks) and saw that the start and end point don’t meet. So i tried to cut the circle with RDWorks and the start and end point were exactly the same. I thought it might be a random error and tested it more than 10 times and the result was the same every time. So now I’m sure this isn’t a random error or mechanical issue.

Has anyone encountered this issue too? I really want to use Lightburn, but as long as this error occurs I can’t.

I hope someone can help me.

I cut circles all the time when I make coasters, I have never had any problem with the circles not cutting correctly. Most of the circles I cut are under 4 inches in diameter, maybe the problem only shows on larger circles. What size circles do you see the problem with?

I tested different diameters from 20mm to 150mm and the offset of the two points is getting bigger the bigger the diameters are. But with RDWork they are all perfect.

Can you post an image? You’re missing some critical info here:

  • are the end points “on the circle” and it just looks incomplete? Or are the start / end offset from each other?

  • what model of controller do you have, and how is it connected? (USB, Net, WiFi)

Sorry for missing informations.

The circle doesn’t look incomplete. The start and end are offset from each other.

I’m using LightBurn on a Mac, which is connected over Ethernet to a Ruida RDC6442G controller.

This is almost always caused by mechanical slop in the machine. Do you have the “backlash optim repay” option checked in RDWorks, in the user tab?

I know that this could cause such problems.

No, the “backlash repay optim” is unchecked. The machine follows the same path in RDWorks and Lightburn.

Do this for me:

  • Generate an RD file using both programs, with the same settings for speed, position, etc - make them as identical as you can, and save both.
  • send the RDWorks generated file to the laser with LightBurn, and send the LightBurn generated RD file to the laser with RDWorks.
  • send me both RD files by email to developer at LightBurnSoftware dot com

Let me know if either of the above tests has the issue of the end points not lining up.

Thank you so much for your efforts!

I will let you know about the test results by the end of the week.

Is the offset in the Y axis or the X axis? This will tell you where the problem is. Then, check all of the belt gear wheels, especially the ones on the end of the stepper motor and, if you have them, where the belts terminate and are clamped. If all is good, you could always enable backlash compensation and adjust the parameter for the affected axis until you get a complete circle. Lasers are no different that most std CNC machines with that regard.

Sorry to dig up a dead post, but I’m fighting this same issue… It started after I upgraded Lightburn today. I didn’t test cut first as I normally would, and killed 3 full sheets of 4x8 acrylic before noticing that the start and stop points were severely offset. it also seemed that it shifted position on the second pass… it did this uniformly. I suspected a head crash, and did a full squaring check. I’m “balls on” accurate on the cut shape size, as well as x/y squaring. it’s just all of a sudden not closing circles. (Photo Attached). I know about the “Backlash Repay” option in RD Works… Does lightburn have a similar option? I found Backlash settings in the new Machine settings tab. Looking at my photo, How would one start attacking this issue? Positive or negative backlash values? Belts, pully, and such are all tight as a drum, and equal as I can see. Thanks so much!

This is a 15" circle run at 50 ipm… that’s pretty slow…

I have this exact same problem and it only happens with lightburn … no problem with t2 or laserweb… all settings are default and its definitely not a motor or tension problem because if more than one pass specified, it will do exact circle for first pass… only one pass has this problem of not finishing full movement.
any suggestions?

If you’re using the “GRBL” profile, it uses velocity ramped power, so if the low PWM setting isn’t high enough this can happen. You can switch to the GRBL-M3 profile to use constant power. I’m hoping to add an option to the standard GRBL profile to allow you to choose contant or variable before long. (And I’m splitting this off, as you’ve tacked this on to a Ruida thread)