Starting Lightburn causes homing action


(Louwrens du Plessis) #1

When starting lightburn it causes one of the axis to move and it carries on until the power is pulled. It is not always the same axis and I have disabled the “Homing” when I installed it. Also, it does not happen every time.
After one or two startups it starts fine with no problems.
My machine has GRBL version 0.9 but I cannot update it.

It also does not come back with the correct position when I click on the “Get Position” button, it is always zero.


(Oz) #2

‘Get Position’ requires the machine to have limit switches and homing enabled, otherwise the controller will not know where it is, so the response will be arbitrary.

If click the Devices button, then double-click your controller in the list and go to the last page you can turn off the “Auto-home on startup” setting there. That should be all that is required. If that button is off you should not see “Homing…” displayed in the console when you connect.


(Louwrens du Plessis) #3

Dear Oz
Thank you very much for the reply. Unfortunately it does not work. The console also does not display “Homing”
I also changed it to the GRBL with M3 mode, still the same.Lightburn
I attached screenshot of the console.


(Oz) #4

Then it does not appear that LightBurn is moving it. If it was, you’d see “homing” in the console. It could be that the board itself is faulty.

Try this: before connecting the board, go to Help > Enable debug logging, then start the board. Wait for the problem, stop it as you normally do, and quit LightBurn. In your documents folder will be a file called LightBurnLog.txt. Post that file here and I’ll be able to say if LightBurn is sending any commands to the board.


(Louwrens du Plessis) #5

Thank you Oz. I will do it tomorrow. But I know the board is not faulty.

I use grblControl for the CNC carving, and LaserGRBL and LiteFire for the laser with no problems at all.

Kind regards and thank you once again
Louwrens


(Louwrens du Plessis) #6

Good morning Oz

I attach the file as requested. As I mentioned, LiteFire, GRBLControl and LaserGRBL works fine.

Kind regards
LouwrensLightBurnLog.txt (36.7 KB)


(Louwrens du Plessis) #7

Good afternoon Oz

I just thought I will send you LaserGRBL logfile as wellsessionlog.txt (635 Bytes)


(Oz) #8

What baud rate is set in LightBurn? LaserGRBL says 115200, but the LightBurn log is filled with incoming garbage as though the chip is connected incorrectly.


(Louwrens du Plessis) #9

Hi Oz

It is 115200. That garbage comes when the stepper motors are moving. I attach a screen shot of the console when that happens. According to the console all is OK?

I also attach a log file, it worked just now, I could move around, up and down etc. I the unplugged the USB, then reconnected and the unit started moving again.

It starts every time after the following

18:37:29.369 D: O: “0a” then the garbage starts coming.

What is the O: “0a” in GRBL commands?

Lightburn3 LightBurnLog.txt (39.7 KB)


(Oz) #10

0a is a line-feed command, like pressing Enter on the keyboard. If that garbage happens when the steppers are moving, you likely have some significant electrical noise issues, grounding problems, or something like that. Try using a different USB cable, preferably one with ferrite chokes on it, and see if that helps.