Step by step instructions please

I have just spent two or three days going through the various ideas for setting this CNC3018Pro up for use.
I’m getting very confused (not like I wasn’t beforehand).
I need step by step instructions to set up the table and LightBurn so they do what I expect them to do.
To my mind, I move the platform to the rear and the Y-axis to the left, so the ‘paper /deck’ match.
Set the G92 x0 y0 so that is the start point coordinate.
Set origin to the bottom left by pressing [Set Origin], both red and green indicators are at the bottom left.
So there we have it, the screen with practice text is onscreen, CNC machine is lined up ready to print.
I press print, so what happens tray tries to move towards me, crunching sounds. I panic and hit the stop button.

What the heck am I doing wrong.

[Edited} Also the setting I show when switching off are different to those that are read from the system on start up]

Please a step by step setup.

While “Step by step” is not directly in the title, this should be helpful to review.

If you use the G92 command to zero the machine you will need to set $10=0 in the firmware settings on the controller.

Otherwise your process looks right. You can also skip using the User Origin and just use Absolute Coords, which places the job on the machine wherever it is in the software,

I’m getting more and more confused, I think the 3018 I have is misbehaving.
The CNC3018 table:
Where do you put it for the initial set up, far away from me or close to me? The reason I ask is I have now tried both and I still don’t have a logical system.
These are the settings used, from another thread somewhere.
Type $22=1 to enable homing
Type $27=5 to adjust the homing pull off
Type $20=1 to enable soft limits
Type $130=300 to set the maximal x dimension (for CNC3018)
Type $131=180 to set the maximal y dimension (for CNC3018)
Type $132=40 to set the maximal z dimension
Using LightBurn I draw a few boxes on the screen and try to print them.
What do I get, horrible grinding noises!
So move the table to Close to me this time (so Lightburn & table are orientated)
Again enter settings above which had somehow changed.
Same boxes again tried to print, oh those grinding noises again.
It’s trying to get to axis points in the negative side of things, Is there a cure, other than me leaving it all alone?? :wink:
I must have something set wrong or the controller is broken???
Anyone any ideas?

Oh yes, when I turn CNC3018 off, then back on later or following day. Most setting have reverted to not what I left them at.


Does the machine have limit switches or homing switches installed? If not, all the homing settings will be of no use. Jog the machine to the front-left using the arrow buttons, then power it off and on again. When it powers up, it treats the power-on location as the origin (zero) so that should help. After that, just set LightBurn to ‘Start From’ : ‘Absolute Coords’ and things should go on the machine wherever they are in the edit area in LightBurn.

OK, thanks for the reply.
I’m in the process of fitting X&Y end-stops. Can’t see the point of the Z-axis for what should be a fixed focus laser??? The glue sticks I was using to fix them was not working very well and some fell off. Pah!

When you say "Jog the machine to the front-left using the arrow buttons"
Do you mean laser over the front left corner of the table or the table as far forward as possible?
This would mean table zero would be at back left.
To me, I always remember that the XY should be bottom left and then the negatives would be down and to the left of that point. Has my ancient years taken that the wrong way :innocent:
Sorry to be so dim on this, but there are two points of reference being used.
Table and screen. If I look at the LightBurn screen, it’s a sheet of paper and I type “Blah Blah” at the top left of the screen, I would have expected this to print on the table as on the screen.
But when testing this was printing upside down at bottom of the paper (testing purposes).
Princy_LightBurn_The confused.

If it’s printing upside down, it means that your origin isn’t in the correct place, OR the Y axis is flipped on the machine itself. Your understanding of the machine coordinates is correct - left-front should be zero, and heading toward the rear or right of the machine is positive movement. It doesn’t have to be this way, but that’s the most common arrangement for GRBL (and most GCode systems).

Thanks, oz.
Sadly things just different each time I open the program and switch on the CNC3018…

  • Quite a common startup is X:83.61 Y:-29.15 Z:3.70. When this happens the stepper just rattles away.
  • X & Y end stops are in place.
  1. Just to be certain. The laser is above the front left of the cnc3018 table.
  2. Am I correct that I don’t need end stops for the Z-axis?
  3. Set finish position to Home position so it always starts from there?
  • When I startup the page in LightBurn shows both green and red square at 0/0 bottom left.
  • My Workspace is 300 x 180 as set up.

I’ll be back tomorrow life is too short and stressful with this ‘simple’ machine haha

Princy_LightBurn_ Still confused

It depends on the version of GRBL you have. If you have homing enabled, and home the machine, a normal version of GRBL will home the Z first, then do the X & Y. You can disable the Z homing, but I think that has to be done at the time the firmware is built.

That shouldn’t be necessary. The finish position is provided as a convenience to move the laser out of the way after a job, that’s all.

Totally flummoxed, not getting anywhere.
Here’s today’s effort from starting up to going for breakfast
I have found LaserGRBL is showing this on start-up.

Top right corner.


From everything off.

Power up PC

Power up CNC3018

Run LaserGRBL to get above snap.

Close LaserGRBL

Start LightBurn

Initialises with the following.

Waiting for connection…

Waiting for connection…

Grbl 1.1f [’$’ for help]

[MSG:’$H’|’$X’ to unlock]


[MSG:Caution: Unlocked]




Target buffer size found


Run $$



































Go to Tab Console and run

Change to MOVE tab

Press [Get Position]

Results in…

I have pressed no other buttons than shown.

So should the values not be zero’d?

X & Y in the ‘Move to Position’ show as zero’s

I Press the button [Go]

This is the result.




Starting stream

Stream completed in 0:00


Jog target exceeds machine travel. Command ignored.

This is the MOVE TAB at this point

What am I missing that will not set the WCO parameter to zero’s?

So if I try to directly set X to zero I get



Numeric value format is not valid or missing an expected value.

How can I reset the whole controller back to its original settings as from the factory?
Maybe I’ve mistyped one of the G settings or seen something I’ve experimented with on a link that does not suit my purpose.
Anything to get it sorted.
Regards Princy_LightBurn

If you move the laser head to the front-left position, then power cycle the controller, when it comes back on, it will treat that position as zero. You can wipe the workspace offset by using G10 L2 P1 X0 Y0. That sets the offset directly to X0 Y0.

Thanks for the reply Oz, I’ll get to it in a short while, but something else has now happened.
Power up computer, Power up CNC3018 and connect USB
Go to Move
[Get Position]
Just as it should be ??
OK, lets now Jog the bottom left of the able to below the laser.
Left arrow,… Nothing happened.
Right Arrow and the laser moved to the left. Pressing the Left arrow key only allowed me to get back to the power-on point…
OK now I have just done as suggested and the information shows as x=0 y=0. However, the Y L&R are still swapped over. How do I get them back to the correct values, please?


If you already have the laser in the front/left position, how can you jog left from there? (you can’t)

I was talking about when it was in its original state before doing your suggestion.
It still has its X-axis the wrong way round. The right arrow will move left and the left arrow will move right.
The Y-axis is working correctly along with the Z-axis (not that I’m worried about that one at this point in time.)
That make more sense?

Sorry not been able to follow on with this due to illness. But I’m back
I’m sorry but I must have a problem controller… I’m just not getting it.
So I’ve been away from cnc3018 for a few days now. No electric etc.
Theoretically Power up X=0, Y=0 and Z=0. That is correct YES or NO?

I power up , start LightBurn, it did an update. Installed etc.

Point 1.
CNC powered down and disconnected from everything.
Start LightBurn, Plug in and start CNC3018.
Go to Move tab. Click on [Get Position] What do I get? X=0, Y=0 and Z=3.70

Point 2
I seem to have got myself into an even worse pickle.
I have a situation where I can move right by 1mm forward by 1mm and visa versa .
I have only one choice I have to manually move the X & Y to the ends of the spindles.
I set X & Y to zero’s but guess what I still only have a single 1mm step L&R or U&D.
I have to power down and disconnect everything for at least 4 minutes before I can power up to get the ability to X=0, Y=0.

Point 3
When I have managed to get something to print everything seems to be printing twice the size of the original on the page. I have set a cube up to a fixed size, 20x20mm, when it prints it 40x40mm. Even though I have the ‘Start From’ set to Current position, it seems to randomly print whatever the test piece is cube , circle or text different each time different.

Does anyone have a set of macros for BASIC settings. Or do I really have a problem controller?

Once again I ask for help please.

Have you set the ‘offset’ that is required for a 3018 ?

My system uses the offset of G10 L2 P1 X-293 -Y178, that may be a start.
Type $$ in the console window then type G10 L2 P1 X-293 -Y178 and press ‘enter’.
That will set your 0.0 position to the bottom left

Hi MooseUK,
OK thanks for the reply. I’m getting totally lost now.
I’ve just watched TV for a few hours, everything off 3018 and LightBurrn.
Just switched it all on and I have, see picture attached

Using the move tab I can move the table forward (away from me) and to the right. There is no movement left nor towards me.
Get Position gives me X=0, Y=0 and Z=3.70
Am I missing the point. Do I have to manually move using the threaded bars each time I start up, then set the zero, then possibly do what Mooseuk has just suggested?

You must try this, set the offset as I have suggested:
Type $$ in the console window then type G10 L2 P1 X-293 Y-178 and press ‘enter’. That will hopefully set your X0 Y0 position to the bottom left of the machine, which is what is required

Thanks for the reply.
I assume I line the table all up manually, then power up.
I am also assuming that the table is away from me so it would be the bottom left corner of the table . That using the manual movement by the screw-threads.
Power up, do as you suggest with that bit of code???
Will give it a go in short while…
Then I have to sort out the end stops. argh, thought this was going to be easy and fun :innocent: :innocent: :innocent:

The result of that was Boot up [Get Position] x=0 y-0 & Z still says 3.70
Ran your suggestion Drew a 20mm square on the top of the Lightburn page.
Set to absolute coords.
selected the square, went to print and all I got was howling motors.

Have not switched off yet, but I can’t get the motor to move, x & Y seem to want to stay where they are.
I’ve just asked manufacturers to send new controller (again) Firstly its’ not working secondly it’s noisy .
Back to drawing board, there are so many different things said on the InterWeb ( :wink:) I have no idea what to do next.
Why would it show a Z axis of 3.70 after it’s been totally switched off for days. Why is it so noisy, WHY doesn’t it work, argh!!