Stepper Motor Y axis grinding noise

Hi All

i have Redsail Laser RSX503050

was all going great and it finished cutting a job(i think it finished) and just stayed where it finished.
when i tried to move it home it made grinding noise and shook back and forth.
turned off machine and turned back on it homed to X and then shook and grind noise not hitting home.
things i have tried.
turned off machine and hand moved gantry is smooth in both directions.
turned on machine and hand moved gantry X axis not moved Y axis moves with like sand in bearings.
used key pad to move forward - back. press forward button once and it moves forward press again and it goes back. both while making grinding noise.
i will try and post Video.
any help would be most appreciated.
i am thinking maybe a poor connection or something.
kind regards

It’s possible that one of the four wires between the motor driver and the stepper is not properly connected. That could cause what you’re seeing.

1 Like

Or it could be a broken wire … happened to me


1 Like

Thank you both for reply’s. so i put in rotary and same thing happened and i have just swapped motor plugs on psu and other motor is doing it now and y motor is okay.

Just for an up date. I found the issue.
It was the driver board. I had swapped around drive motor plug and each time it was same result fromthe one out put. I swapped board from other laser and all worked fine. New board arrived yesterday and all is up and running perfectly.
Thanks again for help.

Near the upper right corner of your board there is an opto-coupler next to C12.
Is pin 5 soldered?

just had a look and it has good dob of solider on the back.
good pickup though.
thanks kind regards

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.