Steppers Grinding/Stalling after job completion


(Eric) #1

I can not find the reason yet but everyday at some point this problem starts where the steppers stall and start grinding and the head doesn’t go back to the Origin.

Most time I have to kill the machine and hit stop in LB to clear it. Sometimes I can power cycle the machine and hit home then origin and it’s fine.

Take a look at this video.

Thanks,
Eric

Settings Below
$0=10
$1=255
$2=0
$3=1
$4=0
$5=1
$6=0
$7=0
(ATC M6, pulse/ff)
$8=100
(ATC Tool Td, milliseconds)
$9=100
(ATC M6 Td, milliseconds)
$10=31
$11=0.010
$12=0.002
$13=0
$19=0
(Softstart, milliseconds)
$20=0
$21=0
$22=1
$23=3
$24=2000.000
$25=2000.000
$26=250
$27=2.500
$28=11
(Spindle freq. 0 to 15)
$30=1500
$31=1
$32=1
$100=158.395
(x:stp/mm)
$101=157.583
(y:stp/mm)
$102=160.000
(z:stp/mm)
$103=160.000
(a:stp/mm)
$104=160.000
(b:stp/mm)
$110=13500.000
(x:mm/min)
$111=5000.000
(y:mm/min)
$112=5000.000
(z:mm/min)
$113=5000.000
(a:mm/min)
$114=5000.000
(b:mm/min)
$120=8000.000
(x:mm/s^2)
$121=3000.000
(y:mm/s^2)
$122=3000.000
(z:mm/s^2)
$123=3000.000
(a:mm/s^2)
$124=3000.000
(b:mm/s^2)
$130=230.000
(x:mm max)
$131=320.000
(y:mm max)
$132=200.000
(z:mm max)
$133=200.000
(a:mm max)
$134=200.000
(b:mm max)


(Oz) #2

Homing happens at a different speed than just G0 moves (which is what LightBurn sends to return to home). You could lower the$120 setting (X accel) or the $110 setting (X max speed) or the to reduce the chance of stalling the stepper, or increase the motor current. The $120 setting is pretty aggressive for a K40.

Your $30 setting is also strange. Most people set that to 1000 (that’s the GRBL default) and Gerbil used to use 2048. 1500 will work fine, as long as you’ve also set the “S-Value Max” to match it in the LightBurn device settings.


(Eric) #3

Thank you. I have stumbled a little bit editing the settings as I was trying to get things to run faster and etch better. (Old board I was running 350mm/s, Mini only getting 220mm/s.)

Still learning how the Gcode is translated in grbl code as I am still trying to complete orders.

I tuned the steppers up to 500ma but they did not like it at all, so back down to 350ma.
My K40 is not Ebay run of the mill.
I worked with a Manufacture in China back to make a better version as I use to buy these by the container and flip/retail these.

Anyways, it just did it again. I am going to work on the setting you mentioned and go from there.

Thanks,
Eric