Strange Lightburn second pass offset

New user, using an AtomStack X7 Pro. Have done a bit of testing and playing so far. Have noticed when the laser moves to a new corner to begin it’s first path, that point is offset fractionally (maybe 1mm?) upon beginning the second pass from that initial start point (usually corner). Easier? Outline of letter L. Laser starts at top left corner, proceeds down etc. for 1 pass. When laser begins second pass from top left it has moved 1mm outwards and proceeds to cut a second line away from the original cutline. This seems to only happen in when coming down to a start point, never from any other direction. Same thing happened on a curve beginning also. Please help.



Doubtful it is a LightBurn problem/cause and more likely your machine has loose parts or belts or is even skipping/losing a micro-step from running too fast. Make sure everything is tight, notthing is loose and if that doesn’t fix it slow the cut down and see if that fixes it.

1 Like

Cheers. I’ve checked belts and rollers. Strange that no other Travel-to-Cut Point direction is affected, only North to South. Will have to check optimisation settings also.

so you’re saying these points where it’s happening are after a move from another cut? If that’s the case then it sounds like what I described as skipping micro-stepping on the stepper motor. You probably have the setting for Max Travel Speed is set too high.

Hmmm, never crossed my mind to check that so I’ll look at it also. If that were the problem would it not appear at some other point?
So on the to do list : Backlash, Start from, Travel Speed, Origin, Recheck rollers & belts, also attempt an engrave instead of cut to see if it occurs.

After you looked for anything loose and didn’t notice anything did you do the other thing I mentioned?

… if that doesn’t fix it slow the cut down and see if that fixes it.

I don’t believe this will change your Max Travel Speed but it sure should make it obvious where/when this is happening.

As for seeing if it happens on engraving, if you set up Lightburn to do the engraving linearly( turn Flood Fill off ) then there will be very few Max Travel moves within the processing. With Flood Fill on it is likely to jump from section to section and that’s where you Max Travel speed will be used.

Haven’t had a chance to do tests yet. I’ll begin the testing this afternoon (Australian Time)

1 Like

Only just had a chance to do a few tests this evening, nothing conclusive. Still learning things but tomorrow I’m able to spend more time testing. Thanks for the help so far.

After numerous unsuccesful attempts to recreate the fault I’d almost given up. I lined up a job today, big area, lots of lines (engraving) and got it to happen. In 2 places. Doing a second pass after homing got the same results. DougL was close I think, it is a stepping problem but I think it’s the wheels. What seemed okay is perhaps something my fingers didn’t notice. This is the x-gantry which was assembled from the factory and all I did was tighten the bottom roller slop slightly. I’ll have a closer look tomorrow. I have some wheels ordered anyway for Just-In-Case, looks like I might need them anyway.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.