Struggling with laser w larger images

I can cut small logos and pics no problem if they’re under 100x100.

But soon as I load a 300x250mm image and click frame or start, the laser head just slams into the side of the cutting area.

My machine size is 65x50.

I’ve set the origin to the lower left corner. Click “set origin”. I can move the head through the software and then click go to origin and it works fine.

But if I click “get position” it returns a negative number.

Look to the ‘Negative Workspace’ section of this document:

Just curious @Shaiss did you run a level on your bed and check to see if the whole bed is square? Larger beds have a tendency to be off.

Here is a fast way to see if your bed is not level on all four corners. I don’t like the way he moves the head manually I would use the control panel to adjust the head but the rest of the video is great showing you how to use a square piece of metal tube to see if it’s “on the level”

Here is the video



The user profile lists ‘Eleksmaker’ as the laser - there is no bed to level. It looks like this:

You haven’t mentioned what ‘Start From’ mode you’re using, and that will play a part here. If your machine doesn’t have homing switches, or zero itself, you’ll need to do that manually, or just use ‘Current Position’ as the origin mode.

Which version of GRBL firmware are you running on it?
If it’s 1.1 or higher, you’ll need to set $10=0.
If it’s 0.9 or older, you’ll set $10=2

These change how the position is reported to LightBurn, so it’s relative to the zero point, not relative to where the machine was when you powered up. You can skip the above by manually homing the machine to the front-left corner before you power it up.

1 Like

I wrongly assumed that these were in inches and it was the size of the bed.

Thanx @LightBurn

I don’t think it’s a negative space machine. I think it’s my fault for not turning the machine on at the origin.

First off thank you for the quick and detailed reply!

Start from is current position. Job origin is bottom left.
Build info says 1.1f.20170801 (not sure if that’s the latest or not)
$10 is set to 1

I used lasergbrl to get that. Not sure how to do that via lightburn yet.

I don’t have any endstops. So I’ll move the head to the front left when I turn it on. Ty!

Type $$ and press enter in the console, or go to Edit > Machine Settings

GRBL 1.1f is great - that’s the version we generally recommend. I think 1.1g or h is the newest, but f is the one where laser support really began to work well, so it’s fine.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.