Stuck at x= -19 y= -19

I cannot seem to clear my machine offset. I have used the G10 X=0 Y=0 but EVERYTIME I home my machine it thinks its at -19 on both axis with the machine at its actual x0 y0 position. Everytime I try to cut, the machine wants to go way out to the far rear right corner and beyond. I can not seem to get it to stop going to -19!!! Im going crazy here!!! Some one please help!!! Running an Xcarve grbl.

XCarve default firmware seems to reset all settings and offsets, which is why we provide the ‘Use Laser’ and ‘Use CNC’ macros. When did you set up your laser, and did LightBurn ask you if it was an XCarve or Shapeoko machine when you did? If so, you should have a Use Laser macro that sets the offset properly, and a Use CNC macro that clears it.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.