Sub-Layer line bug found? Laser shuts off when changing to sub-layer (OLM3)

It looks like I found a bug in 1.2.01 when using sub-layers to cut lines. The first layer runs fine, but when starting the sub-layer the laser shuts off and it continues to run the cutting path. I narrowed this down to a missing M4 command in the gcode when changing from the first layer to the sub layer. Here is a link to the video showing the issue and the manual fix:

1 Like

M4 should be a modal command so should not require it to be resent.

Curious, what happens if you have a simple cut layer with no sub-layers and then have 2 passes? Do you see the same symptom?

When cutting a job without a sub-layer and doing two passes it works fine, but the plot thickens. It looks like I had air assist on in the sub-layer (2nd pass) and the M8 command is what is shutting off the laser. By adding the M4 before the M8 command the job runs. Deleting the M8 and not adding the M4 the job runs.

This feels like a firmware bug. M4 and M8 should not interfere with one another.

Other than that, how do you like the OLM3? How is homing now handled without switches? Does it use a sensorless homing method or do you just use manual homing?

The OLM3 is WAY better than my old LM2. I am cutting 1/4" birch craftply in two passes at 300mm/min and 1/8" craftply in one pass at 300mm/min. Not CO2 speeds by any stretch, but it is great for one-off builds. I’ve only had it running for a few days now, but as long as the diode stays running it was an excellent value for the money spent…once they fix their firmware.

Thank you everyone for your responses.

Thank you for bringing this to our attention. Investigating further. :slight_smile:

@OrturTech Hi Gil, will you take a look and offer some feedback as well? Thanks. :slight_smile:

this is puzzling
On old firmwares there was a “constant power mode”
M3 G0 firmware bug where if a G0 was given laser wouldnt restart

I didnt find it on the olm3 firmware

Could i please have a LBRN file to validate replicate @tra4536
gilaraujo@ortur.cn or here, whichever easier please?

1 Like

Afterthought, @tra4536
IF constant power mode is ticked “OFF” does it do the same?
image

I’ll send you the file when I’m back at home. I have a couple videos up on YouTube showing what is going on. They are posted in the Facebook group.

I have a feeling the M3 bug creeped in on the latest
need to replicate but if so is a easy fix

Could i ask too
$i In console and send the full console dump so i can identify your firmware version please?

IF it is what i think it is
a) work around for the moment, disable constant power mode. Shouldnt cause any issues or any change in the performance, except the G0 G1 sequequence disapears

This should allow laser to work normally

Already reported internaly for replication

2 Likes

I sent you an email, Gil. Your suspicions are correct. While I can toggle the problem on/off by turning the air assist on/off the files work with constant power being disabled regardless of the air assist being on or off.

This one is on me, i found it on 1.85 on Pro S2 machines
Assumed the fix carried over and didnt test!:blush:

Its a simple G0 → G1 sequence bug, was already fixed, But seems it didnt make it downstream

1 Like

Is there a pin on the Ortur main board to allow connecting a relay or solenoid to turn the air assist on/off? I’d love to not do it manually.

1 Like

“soon TM” :smiley:
Product and firmware are on testing phase
3 I/O ports will be Available by Gcode command. ON/OFF

4 Likes

Thanks Gil. As always, very much appreciated friend. :slight_smile:

I should clarify though
Hardware is present already I/O wise on the motherboard, but the firmware cant “see it” yet

1 Like

Sent you a Email message with RC20 firmware, which addresses this bug
Could you help me validate if in fact issue is fixed?

Thanks!

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.