Sudden Laser issues after power outage :(

Hi all!

I have a 90w co2 laser using the Ruida RDC6445G and lightburn software. I have been using if daily for over 2 years with no major issues - until yesterday. No sure if its a coincidence all the below issues started after a power outage at the property (but the machine was not stitched on and switched off at the main power socket).

Main issues

  1. We no longer have any connectivity between the computer and the laser cutter. Will not located the laser by any means. tired/tested with other cables and usb ports on known working computers etc.

  2. The laser head seems to move extremely slow in x/y up/down manual control.

What i have tested so far;

  • Diagnostics mode on the main ruida display - shows no faults.
  • The main board shows 2 led lights. #15 - solid red (+5v) & #14 - flashing red (run - which i believe is normal?)
  • Manually tested the laser from “test” switch on the power unit at the back - worked.
  • Everything else seems to be working fine (laser head control motors, fan, water etc)

Im not sure but it seems to be a power issue? or the ruida boards faulty? but hopefully someone may know more than my limited knowledge. appreciate any help or advice! :slight_smile: thank you

Welcome aboard, hope we can get you going again…

If it wasn’t plugged in and the supply was disconnected when the power failure occurred, I highly doubt there’s a likely or probable cause of any electronics failure from that power failure.

Does the Ruida complete a boot sequence and home properly?

You didn’t mention if it’s usb or Ethernet. Whatever you’re using, you should be able to see it’s presence with the device manager on your machine. If your OS on your pc can’t see it, neither can Lightburn.

If it’s usb, it would sound more like a driver… Ethernet doesn’t have these issues…

Few of today’s types of electronics just fail while operating, you usually find out they failed when you power it up the next time…

Sure, the Ruida could fail and they have, but the status doesn’t show a failure (error led) and I’d look at it last…

  1. does the Ruida complete a power on boot/home
  2. can you see the machine in the device manager


Hi Jack,

Thanks so much i hope so too :slight_smile:

It seems strange to he associated with the power outage since it was definitely switched off. I also used it a few hours earlier and performed normally.

Its USB setup.

It does seems to boot correctly and does go to the home positioning successful. I didnt notice anything out of the ordinary when i start it up. Its just when i try to manually moved the laser to adjust the height for the job i noticed the speed was very slow and seemed a bit delayed (the movement continued for a about 1 second after i released my finger from the arrow keys - where usually it would stop simultaneously).

Im using windows and i cant see the machine on device manage. I tried connecting to a laptop also and its like nothing is connected. No acknowledgement of the usb being connected at all.

This was the lights on the main board for reference. (Attached)

Thanks again for your help!

Lights seem ok… mine does the same thing… the only one you don’t want to see is the #13 led… :sob:

I would go back to the pc and look at the drivers… if the os can’t see it, Lightburn can’t see it…

Have you looked into using the Ethernet instead of the USB… there are no driver or other types of issues with Ethernet…

You just have to deal with a static ip device on the lan.


Hi Jack

So i followed your recommendations and setup via Ethernet and it worked!! Thank you so much. I honestly thought it was a major hardware issue - i guess its a good lesson to rule out the more simple solutions first. I appreciate your time and support :+1: :+1:

1 Like

Glad you’re up again… Ethernet is much better, IMHO…

Have fun… I’ve marked the thread solved…


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.