Sudden problem with Fill In, lines akward

Hi, today my Fill in started working badly. Lines are not straight, and distance between lines are incorrect.
I tought that maybe it was a belt problem, but if i do the same 100 lines/inch in inkscape and then engrave them like “Lines” they result is perfect.
The wrong engraving only happens when i use “Fill in”.
I already checked the PMW and lower the acceleration with no results.
Honestly nothing was changed since it worked before.
I attach an img of the problem.

Machine is an 80w chinese laser with Ruida controller
This is the same as when it worked (for months)
Thank you in advance.

This is interesting and I have a couple of ideas to explore here.

Click the “>” symbol next to Vendor Settings. This will expand the available information further. Please do the same with X Axis Settings and screen-capture the information.

Your screen-capture technique above is perfect. Much appreciated.
Much better than cel-phone screen pictures.

1 Like

Hi!, thx for the prompt reply, i add the other settings.
I didn’t change anything before/after it stopped working properly.


Hi!, i added more images as you told me.
Any idea how to solve it?

Thank you

I have an idea - I’m just confirming now.

Hi John, i still couldn’t solve it by myself, can you share your ideas so i can try something else?

Thank you

Just a thought - Please do a quick check on your belts/motion system for slop, just to rule that out as an issue.

Does this effect happen in both X and Y axis, if you change the orientation of the Fill angle to 90 degrees in the Cut Settings Editor?

My first idea about the decimal separators being conflated does not appear to be the case. I see, from your screen captures that you are using European decimal separators. These appear consistent and quite ok - It did confuse me for a while though.

Something, perhaps odd is the Y-axis Step Length is less than half of the X-axis Step Length. Because the ratio is unusual I am curious if you use (or have used) a rotary attachment on the Y axis in the time that you have owned the machine.

A full screen capture of LightBurn would confirm if this setting persists unintentionally.

In the Engraving Parameters, your original setting for Line Shift at 150mm/s seems fast compared to your Y start speed of 15mm/s. The short y-axis travel distances would keep the speed close to the start speed for regular engraving, but for filling it would select Line Shift Speed 150mm/s. This could cause gantry bounce related to fill and not apply to your running of parallel vectors.

Please confirm that these values are the current values in LightBurn when your engraving symptoms are presenting.

Please test if the Line Shift Speed is the cause of the described symptom by reducing it 50% (or 90% to match the other speed value) and repeating the job.