Switching between Galvo and DSP flips my workspace upside down

I have been using the DSP version of LB for many years with no trouble at all, this week I added a new fiber laser and purchased the Galvo license for LB. I have LB setup to the two lasers and it is able to switch between them and control them as expected. Both seem to have the XY and origin set correctly (since they are working correctly).

But every time I switch between the lasers the workspace (all the art on my LB screen) flips upside down. I can rotate it back and then use the laser with no problem, but what is going on? Why does it flip upside down? My first thought is that the origins don’t match up for the two lasers. But I am not even certain what an origin means for the fiber laser, much less how to set it or change it.

Any advice would be appreciated.
Thanks

This is because they have different device origins (galvo is front-left).

To remedy this, don’t open the art first - run LB, choose the correct device, then load the file. LB 1.4 and up will auto-flip the loaded file to the correct orientation. If you already have a file open, it won’t do that, because it requires actually changing the file content, which would mean the flip would end up in the undo system.

That makes sense, thanks for the quick answer.

Any chance there will be a settings option to prevent inverting the file content when switching between lasers?

Not likely, because it would mean altering the content of the loaded file. The thing that’s changing is your job origin. The vectors aren’t flipping - the entire workspace is.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.