Text issues with latest version

In the earlier version, when I etched text in scan mode, the entire line of test was etched similar to an image, a full line at a time. With the latest version, that has changed. For example, using “Your Name”, it scans Name like normal but may leave a line or two out. Then Your is scanned, but each letter is done separately, then it goes back and fills in the missing lines. The final product is fine, just that it takes longer due to the weird scan method. Am I missing something I need to set in the new version? I can take a video if that would help.

Do you have ‘Flood Fill Scanning’ turned ON in cut settings? This should be OFF for Ruida controllers. Intended for slower systems and causes some issues with Ruida. You also want ‘Scan all shapes at once’ ticked ON.