There has to be a solution

Hi all,

To say I’m pulling my hair out is probably an understatement but there has to be a better way to connect to one of my machines. I have two machines in different locations in our building. 1 is directly wired to a 5 port switch then into a PC and a Mac (and that works fine ish) and the other is connected via a PowerLine Adaptor. Yes I know PowerLines are not the best option but there is no way to run an Ethernet Cable to the other machine without drilling holes through internal walls, chipping plaster away to hide the cable and having your wife in your ear about the mess and the noise.

Connection to the remote machine is at best awful, 99 time out of 100 it will fail to send the job to the Laser. Turn everything else off on that ring main and bingo it works but the amount of work we have (which is a good thing), we need to have both machines going at once and we can’t always turn everything else off. How would the Mrs watch daytime TV?

We could use USB to connect to the machine but that requires carrying a laptop back and forth to the machine which again isn’t ideal.

Please, please if anyone has any suggestions on a more stable connection method then I’m all ears. I know it’s not the same but I have multiple NAS drives using power lines and I can write and read from them all day long with no problems at all.

My ears are pinned back, thanks in advance for any suggestions.


I have the powerline option as well, no problems there.
You can also consider the raspberry pi option as well. (wifi with a special lightburn image)

1 Like

Thanks for the prompt response Bjorn. I don’t understand why my PowerLine isn’t working when they work for everything else. I have noticed that if I switch the Wired Laser, it’s extraction unit and compressor off then I can send no problem. I can only conclude 1 or a combination of those items are causing undue ‘noise’ in the line.

I’ll take a look at the Pi option, I’ve got one collecting dust somewhere. Might be a quick win.

thanks again

@John2411 Is it possible that the issues are not directly related to the Powerline solution? I’m wondering if you have a general problem with the ethernet port on your controller and it just happens to be connected to your Powerline.

Unless the controller is very sensitive to a very specific type of latency or jitter this should work transparently.

It seems you’ve done some sort of troubleshooting but I’m not familiar with what “ring main” means so forgive me if you’ve already tried these but here are some suggestions:

  1. can you reliably ping the controller from your computer with no packet loss? What latency do you get?
  2. Have you tried connecting to the controller through a traditional ethernet cable/switch to see if the behavior is any different? If you continue to have problems that would indicate a problem on the controller side.
  3. Since you say that this works when everything else is turned off, this could imply some sort of routing issue or IP collision issue. Is it possible that you have 2 devices competing for the same IP? Are all devices connected on the same subnet?

I wouldn’t trust that the Chinese Ruidas can handle much, since it’s UDP.

I had a pi, and loaded the lightburn software for the bridge on it and it’s been up and running a couple of months with no issues.

It might be a low cost way to try and fix the problem since that’s what the code that lightburn wrote is supposed to do. And no hole drilling. The Ruida throughput is relatively low for an Ethernet connection.

Do your NAS drives use UDP?

Might be worth a try.


I’ve had no issues using a TP-Link N300 in client mode as a wireless bridge for both my K40 w/ AWC608 and my Red/Black OMTech w/ Ryxon KT332N (Ruida compatible) . FWIW.

Hi Berainlb,

Two things for me that would rule out the controller. The machine is brand new (I know it’s not a guarantee) and if I turn of my older machine and the bits that go with it, connection is absolutely fine. I can ping the device no problem but that use TCP not UDP.

It could well be a routing issue going from my Mac that is wifi back to the router then out over the power system to the device but the distance and complexity of a direct connection is almost impossible. Yep all Devices are no the same subnet but contention with the IP address allocation, I’ve checked. I think the option of using the Pi might be a solution which I’ll try soon as I get a chance.

@jkwilborn thanks again for the recommendation, I think for now that’s the best solution. If the thread isn’t closed by the time I try, I’ll let you know how I get on.

@anon88048707. Good shout, I think it’s either the Fume Extractor which is connected direct to the old Laser or the Air Compressor which is plugged into the wall socket.

@cccMangus interesting, I’m also using a TP-Link 4220 with the wifi turned off.

thanks all

I used a PowerLine adapter for many years with no issues at all - they work very much like a wired connection and are reliable but with a couple caveats:

  • Make sure the PowerLine is on its own circuit with nothing noisy on it. I plugged it into the same circuit as the laser, but not the compressor, chiller, or blower.

  • Connect the PowerLine directly to the wall - If connected through an extension cord, the signal degrades a bit.

  • They come with software you can use to check the connection quality. Use that to ‘tune’ it - try different plugs, different combinations of stuff plugged in, etc. It might be just the plug you’re using - if it’s too far from the breaker it’ll degrade the signal too.

UDP is core part of IP group. Problem, unlike TCP/IP it’s does NO hand shaking, error reporting, guarantee of delivery or duplicate protection. Any unreliability in the network could have major issues.

Some of the code in the Lightburn Pi Bridge is supposed to target some of these, somehow.

I went from a TP-Link N300 to the Pi Bridge, which is smaller with it’s own internal antenna.


Don’t know where you are and what your mains are but if you have the rather typical home power system in the US then you have a single phase 220V drop which splits to two sides of 110V. If one of your outlets is on one leg and the other outlet is on the other leg then communication will be extremely iffy. They do make capacitor bridges that you can put across the two legs that will pass communication across. Same if you have 3 phase 208V. There is a bridge for that too.

all of what Oz said. And remember that motors are noisy, very noisy and not just audible but electrically noisy. SInce you run powerline stuff, I would layout how the 2 legs(US) of the power are distributed around the house and mark everywhere there is a motor of any kind on a leg.

And if after all your designing and isolating of electrical noise still doesn’t do the trick then I would look for a way to get the design GCode local to the machine over a reliable protocol(TCP/IP) and then handle the control over what ever means possible.

Thanks Oz, makes sense although I’m limited for sockets in the garage so everthing is plugged into the same double socket. The Adaptor I’m using doesn’t have software. Touch wood it’s somehow been stable over the last few days. I’m keeping quiet!!



thanks @jkwilborn I think I will try the Pi route see how I get on.

Morning @tmostad I’m in the UK. Not an electrician so wouldn’t want to ‘tamper’ but thanks for the suggestion. A few people have suggested using a Pi which I’ll try after Christmas (too busy right now)

OK so following the advice of some of you, I’ve purchased and installed the LightBurn Bridge, what a difference!!! I’m a happy man. Thanks all and good luck

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.