There was a problem sending data...again

Have been away from the laser for a couple of months, started it up and updated to 9.07. Created a file in Corel and cut it with no issues. Go to cut another file and get the dreaded " There was a problem sending data to the laser" message.
Have tried unplugging, rebooting, new cut file, device button…nothing.
In DEVICES the FIND MY LASER gets nuthin’.
Any suggestions? This is driving me nuts.

Curious…If I hit the pause button in Lightburn followed by the GO button the laser travels to the extreme left side of the bed and travels down, up and then back home. Still can’t send a file though.

Try right clicking on the devices button in the laser cut window.


Thanks Anthony but right clicking does nothing.
I had this issue previously in another version but it seemed to be gone.

There are so many things it could be.

Firstly, get rid of the common - different PC, different USB cable, etc.

The fact that you don’t get anything when prompting to Find My Laser tells me there’s some incompatibility, either in driver, hardware or configuration.

What controller do you have? How do you connect to it? What OS are you using?

Windows 10, Ruida less than a year old connected via USB. Has been reliable for quite a while, successfully cut a job just before this issue happened…nothing has been changed between that job and the problem I have now.

UPDATE. Not sure that it means anything but I can save the file onto a USB stick and I can plug it into the laser just fine. Also, wondering what may be the BEST way to connect the laser to the PC? USB, Ethernet or WiFi and are other methods of connection likely to fix the issue?

Are you running more than one copy of LightBurn? Often when I see this it’s because someone launched another copy to work on their next design, then try to run from that one when the laser is done. Only the first running instance of LightBurn will talk to the laser.

Find My Laser doesn’t work if you’re already connected to it for the same reason.

Nope. Went through several boots of both the laser and the PC to no avail.

Right-clicking the devices button as Anthony suggested will reset the connection. It’s possible a Windows Update has done something to the driver, or you have USB sleep enabled.

Check these suggestions:

1 Like

I do have this problem from the beginning. What i do now is hit the “Device” buttom right click and direct after it click the start button. 96% of the time it will work. I try to find out what the problem is but i can’t find it. So, if someone find a solution is very welkom!

Thanks, running Windows 10 but will dig deeper in the morning. Not sure what I did but I’m back up and running again. Played with the move arrows in LB and the laser responded as it should. I will add that I did try this earlier without success…go figure!

I would try a different USB cable, and connect via Ethernet rather than USB.

Okay…back to square one. If I hit ESC or RESET on the Ruida keypad the PC will “see” the laser via Lightburn and I can move the laser gantry around with the LB MOVE commands but as soon as I try to send a cut job from LB I get the same old error message.
By all appearances the USB cable is fine, I’ve cut plenty of jobs with it including two just yesterday.

Weird. Looking at LCD window on the Ruida display: when I try to send a cut job the laser beeps to tell me there’s a problem and the display on the laser reads: “Frame slop. Work paused. Continue press ENTER. Cancel press ESC.” I’ve tried both and neither make any difference.

Frame slop means there is something in the drawing that is outside the working area of the laser. Check to make sure there are no stray objects in the outer edges of you LightBurn file.

1 Like

Thanks Anthony. New file, start from scratch…same result. Nothing out of frame.

Messed around trying different START POINTS. Cutting now but I have no idea how I got here.

If the laser is giving you an error, that would certainly do it. Also, pressing reset on the laser itself does drop the connection to the software. LightBurn should be smart enough to pick it up again, but I’ll double check that.

Regarding the frame slop issue, make sure you’re within bounds, and have the job origin set properly. If you don’t have a lot of experience with the job origin settings, this should help:

Thanks again Oz for your help. I’ll give that a read!