Transfer failed. There was a problem sending data to the laser

I got this message showing up a few times today - “Transfer failed. There was a problem sending data to the laser. The machine may be busy or paused.” My laser has a Ruida controller and I connect to it using ethernet. It’s plugged into a TP-Link ethernet over mains wiring adapter, with the other end plugged into my router. It’s been working fine for 8 months, but today I hit this problem. I ended up re-booting the TP-Link adapter and after that it worked fine.

My problem is that each time LightBurn posted this error, the laser would start the job and then stop at some inconvenient point, leaving me with a half-finished burn - decidedly not good!. Is there any way that LightBurn could abort the entire job, if all the data doesn’t make it across from the PC? Or some other way of trapping this potential issue before it becomes a problem?

Use “Send” instead of “Start” and it will send the entire job and then you can start it from the laser console after it’s there.

Ethernet over mains… I’ll bet that’s susceptible to noise from a wide variety of sources. I’d ditch that ASAP.

I use TP Link powerline adapters, too, to get from the workshop to the main building. They can quiesce (to save power - duh!) and although it looks like the network is running, it takes a few ms to fire up.

Ruidas use UDP for comms, not TCP, so there’s no handshaking or checking other than a checksum of the data packet.

UDP provides integrity verification (via checksum) of the header and payload, it provides no guarantees to the upper layer protocol for message delivery

I suspect it’s a timeout issue.

Maybe issue a command to the laser before sending the job, to ensure the TP link is active - say a home sequence, or such.

You can turn off the power saving ‘feature’ using the TP link app.

Works great. Completely transparent bridging - doesn’t even have an IP address.

I consistently get in excess of 50MBps.

Of course the quality of your house wiring plays a part - my workshop is new, with new wiring, but the main building has 1940s electrics with a light duty spur/wire with a run of around 50 metres from the switch board.

I use Netgear PowerLine adapters and they work every bit as well as a wired connection, albeit a little slower. Significantly more robust than WIFI.

I had a wireless link for ages and even with dedicated link hardware designed for building-to-building links it was patchy.

Powerline has evolved a lot over the last few years. The ASICs used to modulate over the top of the AC are great at discerning signal from noise.

Tech tip: higher frequency AC gives higher throughput. Your 60Hz adapters should, in theory, perform about 20% better than my 50Hz.

Hi Bonjour and thanks for the full explanation. I will check that power saving setting, but I usually do Frame commands before I press Start, so it should have woken up. I have had these TP-Link adapters for several years, so I think I will just upgrade them

Hi Hank, thanks for the suggestion. I have never used the Send command before as Start has worked flawlessly for months. If I Send it do I have to hunt through the Ruida file system to find it? I seem to remember in the ‘dark days before LightBurn’ that the Ruida filenames were similar to DOS.

Hmm. Well thanks guys for setting me straight on the ethernet over power line adapters. Obviously the technology has improved while I wasn’t watching. I may have to buy one to mess around with.

Yeah, the Ruida controller only handles 8 character file names which is so… 80’s.
The last file you send to the machine will be the first file that pops up when you hit the “File” button on the controller so usually easy to find the one you just sent.
In practice I don’t worry much about file names and I don’t keep many files on the controller. Once I’m done with a job and unlikely to use it again soon I simply delete from controller and if I need it again I open it on the computer and send again.

It’s also a good idea not to let the ruida memory get too full of files. When it starts nearing capacity the controller can get kind of senile and do weird things.

if you press file it will show the last file transferred to your laser (at least mine does)
and me using wifi from laptop to router and power line from router to laser, hardly have problems

If has a register of 99 files - if you try and send 100th, it won’t work.

Yeah 99 is max, but even if you’ve only got a few dozen files and you start getting close to the 100MB(?) limit the machine sometimes starts behaving bizarrely. Apparently it needs some of that memory to take care of business.

The last file you sent to the machine will be the first file you press the File button on the controller, so it is usually easy to find the one you just sent
I don’t really care about filenames or store many files in the controller,because it increases the time needed to accses the file for yourself and computer monitoring software. Once I’m done and I’m not likely use it again anytime soon, I simply remove it from the controller and, if I need it again, open it up on my computer and send it again.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.