Traversal Lines Burning

I have read previous posts without successful resolution
Traversal lines are burning and unable to resolve.
I am running GRBL on Just Lasers 15000mW Laser Cutter And Engraver.
Macbook Pro running Monterey 12.0.1 (21A559)
Issue has occurred since software upgrade to LightBurn 1.0.06

GRBL cu.USBSerieal-1410

Unsuccessful actions trialed

  • Updated software / restarts etc.
  • Toggled constant power mode in Cuts / Layers
  • Typing command line $32= in Console
  • Toggled on/off Enable Laser Mode in Device Settings
  • S Value is set at 1,000 MAX in Device Settings (though I don’t fully understand this and the correlation controller power) and have attempted lower settings (but burn and traversal both adjust vs prevention of burning traversal).

Any advice would be greatly appreciated.

Is this a new setup or was this working previously?

Please send output of $$ in console.

Hi there, this is an existing set up that has been working prior to software update ie. traversal lines have been burning only since update.

When opening a file and selecting device Console displays:
Grbl 1.0b [’$’ for help]
Your GRBL may not support Variable Power Mode (M4).
If your laser does not turn off between cuts, switch to the GRBL-M3 device.

I can/have manually created the GRBL-M3 device.
Issue then is that I cannot connect to this device.
I can only maintain a connection with the GRBL set-up (which causes the traversal issue)
I am using USB connection.

Please let me know.


I have been experimenting further and have managed to gain a connection with GRBBL-M3 device on Macbook Pro. Seems a bug if there is more than one device profile set-up in LightBurn.

A continued (intermittent) issue is that connection is not persistent; ie. I have needed to do a system and hardware reboot on a few occasions as I receive a ‘disconnected’ device status that cannot be resolved when changing to a new file. I cannot always replicate this issue / not consistent.
Full reboot and recreation of device profile seems to resolve but is annoying to have to do this.

Was the device originally setup as GRBL-M3 when it was working correctly? If so, when was it switched to GRBL? GRBL should never have worked.

What version of LB were you using prior to updating? Have you tried reverting to an older version?

Your last update almost reads like a USB/Serial driver issue. Did you update your mac recently/before the symptoms appeared? Do you know what USB Serial driver your controller uses?

One suggestion, do you have the ability to update your controller to GRBL 1.1?

Yes, I was using GRBL-M3 prior to these issues.

On updating I was unable at all to connect to this, and could only connect with GRBL (with the transversal issues). I have subsequently updated the Mac OS to Monterey 12.01.
I am currently running GRBL-M3 (1.1 or earlier).

Okay. This makes sense.

I tend to think this has nothing to do with the LightBurn version. You should downgrade to confirm. You may want to hunt down all LightBurn preferences and also delete them. Not sure about the location on Mac but File->Open prefs folder should reveal it.

Do you have the ability to update your firmware?

OK. I’ll take a look. Job for Monday/Tuesday. Thanks for your help so far.

OK, back from break and have confirm resolved.
Seems the issue was a conflict between the Lightburn update and the former Mac OS Big Sur version update.

Lightburn 1.0.06 (GRBL-M3 1.1 or earlier) and OS Monterey 12.0.1 have restored functionality.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.