Trial download problems

just got a slightly used K40 machine. I have downloaded Inkscape already today, now have been trying to download the free trial of Lightburn with no luck. Actually tried on 3 different computers with same result. The K40 by the way has the upgraded card to work with the Ruida controller already. Keep getting this message: This page can’t be displayed turn on TLS1.0, TLS1.1, TLS1.2 in advance settings and try connecting to again. If error persists contact site administrator.
I’m not the most computer savvy guy, anyone else encountered this or have suggestions? I think I have those settings turned on by the looks of things. Again, this is trying to get downloaded to my computer, not trying to connect to the laser,

If you need, I can email you a copy of the trial. Just let me know.

That would be great, thank you.

I replied to your support message, but I’ll re-post this here for others:

Check the settings shown in this video:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.