Trial version not compatible with TopWisdom?

Hi there. I am new to the laser world, have purchased a new to me Redsail which I am told runs with a TopWisdom controller. The Auto Laser software it came with drives me nuts so I am currently on a trial version of Lightburn and I love it but I cannot get it to work with the laser. I tried connecting my laptop directly to the laser via USB to manually have it recognize without success. Could this just be because of the trial version?

Going off old memory here, but I seem to remember mine coming with two USB ports. One id the incoming from the computer, and the other is for a thumb drive. They are not interconnected, you have to be in the right port to get PC connection. If you have a regular USB and D port, then never mind. Use the D port.

No. There are no limits to the trial except the time you have to use it.

Check what @Dave01 mentions and let us know how you get on. :slight_smile:

Some lasers come with two USB ports, others come with one ‘normal’ USB port a a D shaped port. I want to say it’s technically called a USB-B, but don’t quote me on that.The important fact is that no matter what combination of outside ports you have, they are not interchangeable. One is a dedicated feed from the PC, the other is a dedicated thumb drive port. If you have mixed ports, the ‘D’ shaped port is the one to your computer.

Also, check to make sure the other end didn’t come loose from the controller, or alternatively plug directly into the correct controller port. The feeds to the side of the cabinet are merely extensions.

I’ve tried both ports one is marked USB INTERFACE CABLE and the other U-DISK. the only other port looks like a phone Jack for Network. I tried both ports while trying to re-add the device. TL403-CB is how the controller is marked. By chance is this one not compatible with Light burn?

From an Aug. '19 post from Oz directly:

Do you hear a “chime” when you plug the cable into your computer? Do you see a USB device added to the Windows listings? How did you add this laser to LightBurn, ‘Find My Laser’ or ‘Create Manually’?

This may be worth review:

The interface port is the one you want, and don’t forget to try and plug directly into the controller in case you have a bad extension cable. The ‘phone jack’ port, if it’s 8 pin, is a network connection. Don’t remember what the default address is for the Top Wisdom, but you do have to check it and or change it manually. It is NOT a DHCP device.

When you installed LightBurn, did you check the box on the last page to install the FTDI driver? That’s the chip that talks to the computer over the USB connection. You only need to install that the first time, but you do need it.

https://lightburnsoftware.github.io/NewDocs/Installation.html

I did not do that. Do I need to uninstall now to get back to that? Also, when installing do I need to be connected to the laser via USB?

You can just run the install again and install over top of the current version, then when you get to the choice to install the FTDI driver, you can do that. The laser does not need to be connected to USB during the install, but won’t hurt anything if it is.

1 Like

Ok … thank you all so much for helping me. Good news, I’m getting somewhere. So I have successfully connected my laptop to laser via USB directly to the controller (made the ding and everything) Now in the laser window it says “Ready”. My question moving forward … do I need to use the laptop connected directly every time I want to use it? And use the controls in Light Burn? Or can I save the file using Lightburn to a USB. Will my controller read the file this way? TIA

You can do either - save jobs to a USB stick, ‘Send’ to the controller and run from it, or just click ‘Start’ in LightBurn to send and run the job immediately. LightBurn has a number of features that work well with the laser connected to the PC, but it’s not required that you use it that way.

If you’re saving files to run on the controller itself, use the ‘Save OUT file’ button in the Laser window - that’s the data format used by the controller.