Trocen AWS708S Not communicating

Laser 50w
Windows 10
USB Connection
Lightburn Trial version 1.0.02
Lasercad installed - Not working

Hi all,

Hope someone can help as I’m starting to wonder if the laser is faulty.

I have a 50w Omtech laser, and for the first time in trying to get it connected to my laptop using USB, but it just doesn’t detect the laser. I only noticed this issue after installing lightburn (trial version), but lightburn doesn’t detect anything.

I’ve tried two laptops and two USB leads, one being brand new. I’ve connected to the side of the machine and tried from directly underneath the controller. Nothing happens.

I’ve Installed Lasercad and the driver, which didn’t seem to install properly so I forced it manually. Lasercad cannot find my device, says communication issue.

My machine doesn’t have com ports listed in device manager so I had to select and install from the legacy devices option.

So watching device manager, if I plug in the laser (turned on) no new devices appear, it’s like nothing has been plugged in.

I can ping the machine if I setup ethernet and the laser itself seems to work fine. Device has been powered on when trying to install.

Any help is greatly appreciated laptop is running win 10.

Try connecting the USB cable directly to the controller inside the case of the machine, instead of plugging in to the USB port extension mounted to the outside of the case. Sometimes the extensions fail, or are loose, so that would be a simple thing to try.

If you don’t get the ‘Ding!’ from Windows when you plug in the USB (and the laser is powered up), the USB connection isn’t working yet. At the very least you should see an unrecognized device in your device list, and if the driver is installed it should recognize it as a Trocen/AWC controller.

Hi Oz, thasks for the quick response.

I’ve already tried connecting directly to the back of the controller to rule out the cable, but I get the same … Windows doesn’t detect anything, no unknown devices shown or new devices for that matter. It’s as if I’m not attaching anything.

The controller works, Ive aligned everything, can move xy axis from the controller, but USB is failing me. I’ve even removed the controller from the laser body to check the cables. I’m stumped.

It’s possible that either the USB cable is bad, or the controller itself has a busted USB port - not common, but certainly not impossible. If it works via Ethernet, I’d just use that.

Thanks OZ, is there any limitations using Ethernet, compared with USB?

Also if using Ethernet, does it matter what license I purchase?

Many thanks

None and same DSP license. :slight_smile:

Ethernet is a step up … :slight_smile:

Enjoy your machine…


No, in fact, Ethernet tends to be faster - just use a cable, not wireless, as the protocol used doesn’t do well over WIFI.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.