Trocen Drivers Won't update/Can't Communicate with Laser: Trocen AWC 708C Plus, Windows 10 (Boot Camp on Macbook Pro)


Robbie from Boss Laser sent me here. We have a Boss HP 5598 with a Kern KT200 and a Trocen AWC 708C Plus. I have lightburn installed on a macbook pro with windows 10 installed (bootcamp partition). I can see the awc device in my device manager and it says the drivers are out of date/missing. When I installed Lightburn I installed all of the FTDI package…but still no connection. Lightburn can’t find my device and creating it manually does nothing. I chose serial/usb and nothing. I uninstalled and chose straight USB and still nothing. Please help!

Is there a reason you are not using the native MacOS version of LightBurn? It might be a bit less difficult than trying to unravel mac/win/bootcamp virtual driver issues.

Hi Rick,
Yes there is a long and complicated reason, but not complicated due to software or hardware issues–just personal preferences etc. Windows should still function like Windows. No other issues with the operating system–just this driver issue

Have you tried loading the drivers that come with the controller’s native software (LaserCad I think)?

Yes! I did try that – thank you for the suggestion. I may not have done it correctly though. I have the setup.exe file that Boss gave us when we bough the machine and all files that came with that—what file am i looking for, specifically (if you know the answer, of course)? What kind of file (file extension)?

This is not something I have done personally, sorry. I assume the setup file would present some sort of UI to walk you through the process of installation. Boss would know more about the required drivers to get the software they ship with the Trocen systems (again, I think this is called LaserCAD) working properly.

@LightBurn might have additional feedback here.

Thanks Rick–The setup.exe doesn’t work anymore :confused: I emailed Lightburn but I will definitely try messaging them here if that @lightburn is how I accomplish that. Also, this has been a conversation between Kevin Bacon and Rick James. Probably pretty rare :slight_smile:

@LightBurn – can anyone on the LightBurn side help me with this issue?

Kev, it is me, Rick! Funny indeed. I wonder if this ever really happened? :wink:

I am with the LightBurn team so I am now wondering what you mean by,

When did you get this Boss system? What software came with it originally? Have you ever tried or used software other than LightBurn to communicate with this laser? If so, what is the name of that software?

O haha woops. We got the system about a year ago, we initially used Lasercad and have successfully used lightburn BUT only on the computer onto which lasercad was initially installed. We can’t get lightburn or lasercad to communicate with the laser on any other computer asside from the original pc we installed Lasercad on.

This is the issue then. You will need to get the drivers that are installed with LaserCAD and have those installed and available on any computer you want to use to connect to this laser.

These drivers are required to communicate with this laser system no matter what software will be used. Boss should be able to supply you with a working replacement of LaserCAD. Install that on your target systems first, ensuring the drivers got installed, then install LightBurn.

I will try this–thank you!

Please let us know how you get on. :slight_smile:

I definitely will!

OMG Rick!!! I found the lasercad install folder on the old computer, copied it and pasted it into the same location on the new one, ran the driver install file and lightburn works now!!! You sir are my hero!

Glad you got it all sorted.

I was just going to suggest installing LaserCAD, and looking for the ‘Install USB driver’ drop down that you find there. Glad you got it sorted.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.