Trouble adding a 2nd Laser (new)... LB not finding controller OR wrong controller

Hi All,

First off, I got to say that coming from a graphic design background and purchasing thousands and thousands of dollars worth of software over the last 25 years (Adobe - Corel - Vetric - Aspire - Flexi - SignLab - Wasatch Rips - etc) Light Burn is a terrific program and an absolute bargain — we all should be thankful. Just a great program for laser cutters (and costs peanuts)!

My issue…
Trying to set-up new laser on laptop.
I used a laptop with a trial license because my other laptop is running my other laser. When I went through the set-up Light Burn found the laser and classified it as… GRBL-M3 10x10.

However I BELIEVE I have a Ruida DSP controller. I looked through all my paperwork but the controller version is not listed so I have attached a pic of it - hopefully that helps.

After trying the GRBL-M3 version I kept getting an error at output: “Laser is busy” (or similar wording). So then I deleted the GRBL device and added

a controller manually selecting the Ruida. Again I got the same error when trying to output.

So then I grabbed my other laptop that has a Ruida laser installed and is used daily. The set-up for this laser (Ruida 644XG) was easy and flawless. However when I try to add a device now Light Burn does not find any device - not even the GRBL-M3. I did try to manually set-up both Ruida and GRBL devices at separate times but I kept getting the: “Laser Busy” error.

This is a link to the laser…

Any help would be greatly appreciated.


Can anyone help?

Yes, that is a Ruida controller as stated on the page you linked. :slight_smile:

Did you install the driver option at the end of the LightBurn installation? You will need to ensure you have that or the driver installed with RDWorks.

Thank you Rick. I did not see the option for the driver. I will start over again tomorrow. I wonder why LB originally assigned the GRBL controller.

I appreciate your help!

That is a bit confusing. Holiday Cheer? Or maybe @LightBurn has a thought.

Older versions of LightBurn will assign GRBL-M3 to pretty much anything as the “default” if it can’t come up with anything else. It also won’t “Find my Laser” if the laser is already connected, or attempting to connect - it’s a bit like trying to call yourself on the phone.

That is a Ruida controller, and if the FTDI driver at the end of the install process was installed on your computer, it should find it. If you delete the existing laser profiles it will automatically pop-up the device setup when you run again.

1 Like

Thank you Oz.

I did get LB and my new laser (Ruida) to work on a laptop that has a permanent license however I still can’t seem to get the two communicating a different laptop and a trial license.

Different laptop / trial Lic…
After I manually create the device I still get the error when trying to run the laser. If I let LB select the controller it does default back to the GRBL. I did not find a option to install a driver when manually adding the Ruida. Maybe that’s my problem??


Re-install LightBurn itself on the laptop. On the last page of the installer is a check box for the FTDI driver. You only need to do that once, but you do need it.

Thank you Oz… You are a genius!!!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.