Trouble getting 410C / Topwisdom to find my mac... NOOB

hello, I’m having issues getting lightburn to recognise my laser cutter when using a mac. It runs on TL-410C / Topwisdom. I have a rubbish old windows seven and it recognises that works but as everything else i do is mac based and I’m wanting to use it in conjunction with Affinity Designer (which wrks but only by thrsfuring the ties which is a pain.

I love this programme so far, but hate using windows computers and working across OS. Is there a way to get the laser to recognise the mac? I have done a manual install and no luck, I have tried different USB ports and no luck.

When I installed the trail on the windows machine it installed then later asked me if i wanted to install additional drivers. This did not happen with the mac? Or at least i don’t think so. Is their a way to add these drivers?

Sorry for the garbled message, Lawrence

Top Wisdom does not recognize a Mac, most of the laser controllers I’m aware of do not.

TopWisdom uses the same driver as Ruida, and they conflict with a driver shipped with MacOS for virtual serial devices. This might help solve it:

My mind is mush, I meant to say the AutoLaser program doesn’t. Sorry for the serial protocol / program mix up.

no worries, i got what you meant

Thanks for your Help OZ but this So this did not work for me, probably because I’m using mac OS Catalina version 10.15.7… but the following did so hopefully this might be helpful for any future mac/ top wisdom users.

Install FTDIUSBSerialDriverv 2.4.4 using the link below

(I rebooted trying to work out but you may not have to)

When you reboot will get a message saying something like pen drive may cause damage, move to bin, cancel/ ignore this)

try light burn.

if not successful Do as RevK says on

Going to System Preferences, Security and Privacy, it showed text “Some system software was blocked from loading”. However, this was subtle as the adjacent “Allow” button was not active. It was not immediately obvious but I had to “unlock” the window, and then I could click Allow, and select FTDI to allow the driver.

try light burn…

if not successful Install FTDIUSBSerialDriverv 2.4.4 again (no idea why this worked for me but it did)

Reboot again…

Again you will get a message saying something like pen drive may cause damage, move to bin, cancel/ ignore this)

light burn now worked for me. and even auto loaded/ recognised my cutter type and size

Thanks to James Medd for working this out for me

1 Like

Nice! I’ll make a note of this for others. MacOS has been a big pain in the butt with the FTDI driver issues. Not many people realize it’s completely out of our hands, and complain when LightBurn doesn’t work with their laser on a Mac. Thanks for posting this.

Hey Oz FYI the 2.4.4 driver is 64 bit just in case you get asked for drivers that work on 64 bit system

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

For anyone on this thread, I’ve been told that this FTDI driver may fix the Mac USB connectivity issues: