Trouble with files not uploading to Ruida

Today I tried to upload a larger file; over 5000kb. Even after clearing my Ruida controller and formatting it “speedly” I still can’t upload the file. I have an Ethernet connection. It will upload a portion; different amounts of the file each time, then I get the “your controller may be paused or busy” error. Suggestions?

Are you connected with a cable, or over WiFi? I don’t recommend using WiFi because the Ruida controller’s network connection is such that if a packet ever gets dropped by the network there is no mechanism provided to re-try and recover. A wired network connection is much more stable, though if you are going through several router hops you can have the same issue.

Wired Ethernet connection. I used to use wired USB and had no end of connectivity problems, so we switched over. Usually it’s pretty good and way faster - this file just wouldn’t go.

Very strange - USB is generally rock solid unless the wire is really long, and wired Ethernet is very reliable too. 5Mb isn’t a large file in the grand scheme of things - I’ve sent much larger.

There is a setting for network timeout in Edit > Device Settings. I believe the default is 5 seconds (5000ms) but you can go higher. If the controller is pausing to do anything, a higher number could help.

The controller memory isn’t full is it?
If you have a lot of files already on the machine you might want to try deleting a few and see if that helps.

Ok, I reset that to 7 sec. Thanks!

Edit: I tried it again and this time it went. Previously it would reach a certain point, have a long pause and then quit - this time it muscles through those pauses so I’m guessing resetting that did the trick. I don’t know why my controller is so laggy - maybe I’ll give AP tech a call.

I cleared the memory and reformatted it after the first fail. (This isn’t my first rodeo! Lol. I tend to work in complex designs.

Hey, Oz, on a slightly related but slightly different topic; I’m often working with complex files/multiple images, and lately Lightburn’s been a bit… epileptic. The cursor randomly stays on, sometimes with a piece of my design attached, sometimes a function like draw a box is stuck on and I get boxes all over before I can get it off… I turned off antialiasing and reset my auto save for every 7 minutes to try to reduce the load but is there anything else I can do to make things run more smoothly?

I suspect this is related to the framework change we did for 0.9.12. It caused problems on a number of systems, so we’ve reverted that. We’ll be releasing an update soon to correct it, but have a couple things in progress that need more testing first. Are you on a Windows system?