Troubleshooting Ruida Networking

Software won’t recognize 55w laser (Ruida) on Mac- Big Sur

Many posts describing this and the solution.

Big Sur changed the FTDI driver

Is there a reason you don’t use the ethernet interface?

I’ve tried both the ethernet and usb connection, and neither are being recognized int he software.

That indicates more of a problem than you are describing.

They use completely different subsystems - if it doesn’t work with either USB or ethernet, you have multiple problems.

I use MacOS, and have found it remarkably stable on ethernet.

If the machine is turned on, can you ping it?

It won’t recognize it at all. I’m using an adapter to connect ethernet to the usb c.

I should also add that I’m a complete newbie and chances are that there’s a pretty simple solution but I just can’t figure it out.

Can you ping any other devices?

Download LanScan - great tool for the Mac, or locate the network utility and leave it in continuous ping mode as you turn the laser on. ‎LanScan on the Mac App Store

Where In The World Is Carmen Sandiego Network Utility?
If Network Utility is no longer in the Utilities folder of the Mac, where is it? Looking at the path to the app, it’s hidden away in:


There are three much easier ways to find Network Utility and launch it without digging around in hidden folders. The first is to go to the Apple Menu, select About This Mac…, click on “System Report”, and then select Network Utility from the Windows menu. The second is even easier; click the Spotlight search icon (it looks like a magnifying glass) on the right side of the Mac menu bar, then type in “Network Utility” and press the return key.

It’s picking up 51 devices, and I don’t see Ruida for any of them.

So the problem is with your controller.

What is your IP address range, your router address, and the IP address configured in the Ruida?

and 51 addresses! Dude, you’re a networker, fo sho!

Uhh… I only understand 1/3rd of what you said, haha!

ip config in Ruida is

And what’s the address of your internet router?

I sent you a message! A little uncomfortable sharing it publicly.

In which case you won’t get an answer.

Nothing you can tell us about your network makes you susceptible to outside interference and answering your question in public creates a base of solutions that can help others.

:grimacing: told ya I was a newbie!

OK, that’s your outward-facing IP address to your ISP.

You can find it on the Mac network settings:

Screen Shot 2021-04-03 at 2.55.16 PM

This is what I see in network settings

That ain’t right, and it isn’t how my settings panel looks, but I’m using Mojave out of protest :slight_smile:

Try setting it to ‘using DHCP’ instead of ‘using DHCP with manual address’ and see what happens.

Are you using wifi as well as ethernet?

Wifi for internet and ethernet connected directly into the laser.

Your ethernet adapter and ruida have the same address -

Change the address on your Mac to .101 or something else that isn’t in your list of 51 herbs and spices devices

Also, you can’t have your ethernet and your wifi in the same IP domain - the computer won’t know where to send packets.

What’s your wifi IP address?

EDIT: easier to just start from scratch.

Set your Mac ethernet address to, set your Rudia to with either a router address of or a mask of, depending on which it is expecting - some like a router address, some just ask for a netmask.

That will work.

Shows as connected in network settings, but Light Burn still doesn’t recognize the device.