Trying to finish a few Xmas presents

Is there someone who can help me get my laser functioning again?
I don’t understand how to correct the problem involving the Homing fail.

Right now the laser moves about halfway up and along the left edge of the laser bed where it stops… The laser will not respond beyond that point.

I have the origin of Lightburn set to absolute coordinates. The red and green squares are set and appear at the x0,y0 lower left.

How do I handle the Alarm 9 and the MSG: $H|$X to unlock?

Below is the console information.

Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.
Ortur Laser Master 2 Ready!
OLF 137.
Grbl 1.1f [’$’ for help]
[MSG:’$H’|’$X’ to unlock]
[MSG:Caution: Unlocked]

How did it get to this state?

Have you tried turning the machine off, manually moving the laser head near the homing position, then starting the machine? What happens?

First thanks for taking the time to respond, especially this busy time of year.

How did it get to this state? Strongly suspect it was me accidently doing something I shouldn’t have. My Parkinson’s shakes sometimes over take me.
Yes, I have turned machine off and on. Did move laser head near homing location. The laser will head off to the middle and left side of the work surface.

I have gone through reinstalling the .ini files, Flashing the EEprom with firmware version 1.40 . The only area remaining to check are settings for the ‘Machine Setting’ values found under EDIT on the menu. I don’t know what the correct values are for the Homing section should be. Would it be possible for you to provide a screen capture of that section? It might help.
Thank you so much

Check all the plugs and connections to the physical switches for your end stops, and make sure that there’s nothing preventing the laser head from reaching them and they’re not bumped out of place. Also make sure the machine is actually powered correctly - if your power plug isn’t plugged in, or the machine isn’t turned on, the board will wake up but motors won’t move.

Does this mean that you changed a setting or something happend mechanically? Or you’re just not sure?

What does this mean? Are you getting an .ini file from an external source? If so, where?

Did you do this after your initial post? That one indicates firmware version 1.37.
This should have restored all configuration values to default.

Can you issue $I, ?, and $$ one at a time in Console and paste the output of that command here?

Somewhere I read that if you deleted the .ini files that Lightburn created. Lightburn goes through the install process like the first time you installed the laser. That did work cleaning out any bad setting and put in the ones Lightburn originally installed.

I will go back over the wiring, checking for loose connections. Sure would be embarrassing if that is the problem but at this point I would be so happy.

I also tried Firmware 1.37 but it didn’t help. I moved on to version 1.4. It didn’t change anything so I decided to leave it alone.

I will go to the console and enter the commands:
$I, ?, and $$ … One at a time and copy and paste information here.
I’ll send those results tomorrow. Hope that works for you.
Again thanks for your help…

What’s interesting is that the laser head is moving away from the homing switches. This could happen if you changed the homing direction or if you had inverted the stepper direction but those wouldn’t survive a firmware update.

Can you confirm that when you turn on the laser that it immediately moves away from the homing location? Or does it first hit the limit switches and then move away to the final position?

Have you recently rewired or reconnected the stepper motors? If so, make sure the cables weren’t misinserted in some way. Check also on the board side.

If the laser head is first hitting the limit switches and then moving away after they’re then specifically check for the wiring on the limit switches themselves. Also on the board side.



[MODEL: Ortur Laser Master 2]

[OLF: 140]

[DATE:17:23:54 - Jan 4 2021]



Target buffer size found




Homing fail. Could not find limit switch within search distance. Defined as 1.5 * max_travel on search and 5 * pulloff on locate phases.







































Your config looks straight default as would be expected after the firmware update.

Once you get a chance to do your examination and review my other questions let us know.

Also review this post from @OrturTech. He has a picture for specific connections to check and more checks for power as well as testing procedure.

I assumed you weren’t having a power issue since you said the laser head was moving but perhaps it’s a failing but not fully dead power supply.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.