Unable to get Lightburn to see my Laser module - Snapmaker Original

Hello All; sorry to ask this obvious question… I have a Snapmaker original 3D printer/Laser/CNC machine. It connects from the Snapmaker’s USB/serial port (USB A) to Snapmaker’s software (USB B) and works.

In Lightburn, the same connection is not found and I have no idea how to test it or configure it. The console just states Waiting for connection. At start up my machine was not found and was manually created and the Snapmaker name and Marlin were present in a list so I clicked on them, entered the X & Y dimensions.

The software looks very interesting and I would like to know what I am doing wrong (or not doing at all) so that I can connect my laser module and Snapmaker to Lightburn. Computer is a Mac running Catalina 10.15.6. Any help would be much appreciated. Today was my first day with a Lightburn trial copy and it is disappointing that I cannot get it to talk to my Snapmaker. TIA

I’m not sure what baud rate Snapmaker users, but it’s Marlin based, and it’s common for Marlin systems to use 250,000 baud. You can change this in LightBurn under Edit > Device Settings, then along the right side of the window near the bottom is a baud rate option. I would try that to start.

Thanks for this information; I had the baud rate set at 250,000 at the start. I wondered if there were a series of steps or tests that I can run. My issue seems to be just connecting yet my computer connects through the Snapmaker supplied software. I figure there is some part of the set up process I have not yet done.

I will say that the Snapmaker support is brand new, and we don’t have one of their units here to test. The profile was added with the help of another user here who did testing for us, and I know very little about the machines. See if you can figure out what SnapMaker is actually expecting for baud rate, because I could easily have that wrong too.

Thank you. I will try and see on the Snapmaker site. Mine is the version 1.0 iteration and version 2.0 is the current one. I think the hardware specs may help as well and I will update the firmware. As far as I can recall it is running Marlin/grbl 1.1. I am not very technical and it would be easier to troubleshoot if the Snapmaker software did not work through the USB/Serial port but it does so my computer must be seeing the machine correctly. I am going to read through the Grbl setups document a few times and see if I have followed all of the steps. I watched the useful set up video too but I could not see where I have missed a step. I will come back to the forum with better information.

edit Is it possible to run your software in some mode that lets me run the Lightburn software without it being connected to my Snapmaker?

OK, I have updated the Snapmaker firmware to GD32 Base 2.11. Marlin is the current flavour of Marlin.

Yes - If you’ve created a device, you’re already in that mode. You can create a design and just click the ‘Save GCode’ button near the Start / Stop buttons to save the GCode to disk, copy that to your machine or use their provided software to send it.

:ok_hand: Thanks Oz

@LightBurn @jepho the correct baud rate is 115,200. I’m struggling with a Snapmaker too.
I was supported by another user that successfully used the machine.

Mind to check closely the laser height to avoid the head to hit the bed plate :smile:


Thank you @jlropes. I was reliably informed (from the Snapmaker forum) that for Snapmaker v1.0, the baud rate was 250,000. It may have changed with Snapmaker v2.0 which is your machine. I will try it at the lower setting and see if that helps. Your link leads to an error message that the page does not exist or is private so i was unable to view it.

The head hitting the bed is a Snapmaker issue.

I hope the new baud rate could work for you.

You’re right. I didn’t considered that post was private. I suggested @Voidoids to share with everybody his incredibly useful workflow to make the Snapmaker works with Lightburn.

Thanks again. I was able to get it to work but I need to work with the instructions for Lightburn. I was not seeing new layers created with each new component and I am not sure why.

The baud rate helped me to see that it was not present as a network option while the Snapmaker name fooled me into thinking the software knew what I was trying to do. After connecting up, I was able to apply the network name in the devices drop down, which had been blank. I will increase the baud rate again to see if the lack of network name connection in the device drop down was all that was preventing me connecting. My own stupidity really. Thank you for your help.

Here the great job of @Voidoids!


1 Like

Thanks a agin… it is very much appreciated. :smile:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.